Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Anonymous
Not applicable

Python Visual - Dataframe Doesn't Load

 

Hi Power BI community,

 

I need your help. I am trying to create a Python visual in Power BI Desktop; the code works fine, but the visual doesn't load the data from the data model into the dataframe. Therefore the graphs remain empty.

 

It's really frustrating...

You'll find an example - screenshot - down below.

(Excuse the child's painting)

 

Some background information:

  • The data is coming from a Power BI-Dataset created and managed by my employer, which I have limited access to.
    (I'm not able to use the Power Query Editor on that dataset, nor can I combine it with additional data sources)
  • I've created a new virtual enviroment and installed the compatible versions of python and the packages.
    (With pip and conda - tried both)
  • I'm working with Anaconda and Jupyter notebooks

 

Could it be that there a limitations when using a pre build Power BI-Dataset?

- Maybe it's my limited access

 

I would be extremely thankful if someone has a clue or solution for this problem!

 

Thanks in advance.

 

Best regards,

Felix

 

 

 

Screenshot 2021-09-10 082351.png

4 REPLIES 4
lbendlin
Super User
Super User

You may have filters on your Values A and B that result in an empty dataframe?  Hard to tell without more context.

Anonymous
Not applicable

@lbendlin Thanks for your Input. 

 

I think I know the reason; it seems that it has something to do with the Power BI dataset from my employer. Maybe some sort of restricions. (I have limited access to the dataset. I can use it, but can't make any changes. Can't even use the power query editor)

 

I tried it with data from an Excel sheet and the Python visual worked perfectly fine.

 

Possible Solutions:

A - I need to find a workaround, to exctract the data from the system and import it into Power BI

B - I need to get some special authorization / access to the dataset (Which is highly unlikely)

 

Any other ideas are welcome 🙏

 

Best,

Felix

lbendlin
Super User
Super User

@Anonymous   You are supposed to use the prefilled "dataset"  dataframe, not fill your own.

Anonymous
Not applicable

@lbendlin I know. That's the point of my question, the "prefilled dataset dataframe" is not loading by itself. Any idea what's the reason?

 

Best,

Felix

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.