Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
rnimmala
Frequent Visitor

ODATA data load issues

Hi Team,

I am getting below error while trying to connect to SAP HANA data through ODATA service URL.

 

The server only lets us extract a max of 5000 records. When we try to extract more or all the records we get the error below.

 

DataSource.Error: Microsoft.Mashup.Engine1.Library.Resources.HttpResource: Request failed:
OData Version: 3 and 4, Error: The remote server returned an error: (500) Internal Server Error. (500 Connection Timed Out

2024-04-26 10:50:25)
OData Version: 4, Error: The remote server returned an error: (406) Not Acceptable. (Not Acceptable)
OData Version: 3, Error: The remote server returned an error: (500) Internal Server Error. (500 Connection Timed Out

2024-04-26 10:51:35)

 

In the Power Query, we even tried to increase the timeout duration, but the issue still persists.

 

Can someone please suggest how to fix the issue?

 

Thanks

 

1 ACCEPTED SOLUTION
v-zhengdxu-msft
Community Support
Community Support

Hi @rnimmala 

 

You mentioned attempting to increase the timeout duration without success. It's crucial to ensure that the timeout settings are correctly applied. For Power Query, the timeout settings might need to be adjusted in multiple places, including the data source settings and gateway configurations if applicable.

For more on setting timeout values, please refer:

Solved: Odata #timeout parameter not working? - Microsoft Fabric Community

excel - How to set a max run time / timeout for Power Query? - Stack Overflow

How to increase the timeout of Odata, I am getting... - SAP Community

 

To work around the 5000 record limit, consider implementing pagination or server-side filtering in your OData query. This approach allows you to retrieve data in chunks or only the specific records you need, thus avoiding the limit.

Here for your reference:

URI Conventions (OData Version 2.0) · OData - the Best Way to REST

 

Best Regards

Zhengdong Xu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
v-zhengdxu-msft
Community Support
Community Support

Hi @rnimmala 

 

You mentioned attempting to increase the timeout duration without success. It's crucial to ensure that the timeout settings are correctly applied. For Power Query, the timeout settings might need to be adjusted in multiple places, including the data source settings and gateway configurations if applicable.

For more on setting timeout values, please refer:

Solved: Odata #timeout parameter not working? - Microsoft Fabric Community

excel - How to set a max run time / timeout for Power Query? - Stack Overflow

How to increase the timeout of Odata, I am getting... - SAP Community

 

To work around the 5000 record limit, consider implementing pagination or server-side filtering in your OData query. This approach allows you to retrieve data in chunks or only the specific records you need, thus avoiding the limit.

Here for your reference:

URI Conventions (OData Version 2.0) · OData - the Best Way to REST

 

Best Regards

Zhengdong Xu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.