Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Ash1
Frequent Visitor

Modify query after datasource is created

Hello 

 

Is there a way to modify the datasource from which data has been loaded to PowerBI?

 

Initially when I have created a report, I used Import query option to retrieve all the records, with all the columns in a SQL Table. The table has more than 65 M records and now when I try to refresh the query, it fails with memory not available erorrs.

 

What I'm trying do it to limit to only the columns that I need to get the report functional. so I tried,  to add the query wiht the where clause 

 

Edit Queries -> Data Source Settings 

 

However the query window is greyed out. Is ther a way out without building a new report altogather?

 

Thanks

8 REPLIES 8
Phil_Seamark
Employee
Employee

Hi @Ash1

 

If you can get into the Query Editor try clicking this button

 

Query Editor.png

 

Hopefully it brings up the query window where you can replace your query with one that contains just the columns you need and perhaps a WHERE clause that restricts your rows to exactly what you need.

 

 


To learn more about DAX visit : aka.ms/practicalDAX

Proud to be a Datanaut!

Thanks for the reply,

 

It allows me to update the qeury, but I'm running into issues when I'm trying to apply the changes 

 

Error: The key didn't match any rows in the table

Details: 

Key= Record

Table = Table 

 

 

~Ashwin

Hi @Ash1,

You click the button as @Phil_Seamark posted, you will get the Navigator like the following screenshot.


1.PNG

You use the same SQL Statement in highlighted line area as in SQL Server, it return the error message? It's weird. Please close the Edit Query and open it, and check if it works fine.

Thanks,
Angelia

Oh ok, so maybe edit the query to limit the rows and use the Query Editor to remove the columns.  

 

Can you revert the query back to what it was but just put a TOP 100 in the SELECT ?


To learn more about DAX visit : aka.ms/practicalDAX

Proud to be a Datanaut!

No luck.

 

I tried selecting all the columns with the dateadd fileter to limit rows. I'm seeing same error 

 

The key didn't match any rows in the table

are you getting the same issue if you run the query in sql?





If I took the time to answer your question and I came up with a solution, please mark my post as a solution and /or give kudos freely for the effort 🙂 Thank you!

Proud to be a Super User!




No. Query runs fine on SQL Server. 

Hi @Ash1,

Have you resolved your issue? Please mark the right reply as answer. If you have not, don't hesitate to ask.

Thanks,
Angelia

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.