Forum Discussion

db042190's avatar
db042190
Icon for Impactful Individual rankImpactful Individual
11 months ago
Solved

trying to add pipeline using on prem sql server - getting azure sql error instead

Hi i just started looking at fabric.   I'm trying to add a pipeline to my ws with fabric capacity  as shown at https://microsoftlearning.github.io/mslearn-fabric/Instructions/Labs/04-ingest-pipeline.html .   admittedly i was supposed to see a COPY activity (late note, apparently the context i was in was COPY) according to those instructions but sort of went with what i got which was to pick a data source.  for the data source i chose an on prem sql server.  but i'm getting an azure sql error instead of on prem error as shown below.   this source isnt azure.   i believe the only choice i had for gateway was correctly seen by fabric.  i tried different combos of both my email and "AD with domain account" separately, as well as auth method , encryption, being prompted to login with my email , privacy level, new conn  etc.   eventually i got an error saying a conn was made but the "cert chain wasnt trusted".   I was usrprised to see that my nonexpiry conn that we started using didnt show in the conn dropdowns.   can someone help?

 

 

16 Replies

  • 3000.214 is the March 2024 version.  Your gateway must run a really, really old version.  Consider upgrading.

    • db042190's avatar
      db042190
      Icon for Impactful Individual rankImpactful Individual

      thx ibendlin.   i know there is a gateway client install on the client, namely our sql server.   But have to believe there is one higher perhaps in the cloud under our tenant.  Which (or both) would you upgrade?

      • db042190's avatar
        db042190
        Icon for Impactful Individual rankImpactful Individual

        our dba ran a ps script (2 different ways, one with get-item property, one with get-ciminstance...) that shows 3000.202.13.   im guessing just from what i saw in his output that this is at a level higher than the dw client gw that i think had to be installed on the dw also.

  • db042190's avatar
    db042190
    Icon for Impactful Individual rankImpactful Individual

    this is a bit of an education for me.   I found this by navigating to admin powerplatform.   I was surprised to see the same "on prem server" also being where the "gateway is installed" (do i have that right?).   I looked inside the file to find "sqltrustedservers".   It wasnt there.  I was also surprised to see its online but not enabled as shown in the image.  What does that mean, especially not enabled?   I made a copy of the config file but will stop short of following the instructions till my network guys are on board with this.  I'll see if i can learn somewhere how/where a node called sqltrustedservers would be added.   its kind of weird to think the entry would basically be saying "trust myself" in terms of which servers are to be trusted.  I'm also starting to wonder if a gw cluster is different from the gw itself and maybe i'm barking up the wrong tree.   cluster sounds more like a failover thing.

  • db042190's avatar
    db042190
    Icon for Impactful Individual rankImpactful Individual

    guessing at the moment that this is where that trusted server node would be added

  • Anonymous's avatar
    Anonymous
    Not applicable

    Hi db042190 

    I wanted to check if you had the opportunity to review the information provided. Please feel free to contact us if you have any further questions.


    Thank you.

  • Anonymous's avatar
    Anonymous
    Not applicable

    Hi db042190 

    May I check if this issue has been resolved? If not, Please feel free to contact us if you have any further questions.


    Thank you