Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
sandraf
New Member

We cannot convert the value "[Binary]" to type Binary. Table: Data

I have created a PowerBI Desktop Model with my data source being a Sharepoint Folder.

 

I have been able to import and combine my files within the folder and refresh the model successful via the desktop.

 

I have now published to powerbi.com and I'm getting the below error when I try and refresh

 

We cannot convert the value "[Binary]" to type Binary. Table: Data

 

Any ideas?

12 REPLIES 12
Anonymous
Not applicable

I wonder if this happens when the service version gets out of sync with the desktop version or some such process.  I can have sharpoint combinations working fine but then one day they do not and I get the [binary] to binary error.  This is without any slipping of from organisational to private.

You can see in the desktop that the files are imported as binary.  If you replicate the same import in a dataflow in the service you see them imported as [binary].  The service is doing the import differently from the desktop although the code is identical.

 

I have moved all my combinations into dataflows and I reference the combined file from the dataflow into my dateset in the desktop.   Then I do not get these anomalies.  

 

 

Anonymous
Not applicable

I often get this error when using SharePoint or other dataflows as input. The cause in my case has been that for some obscure reason the authentification changes from Organizational to Private - check the source files credentials

Thank you so much - solved my problem! 🙂

Thank you. This comment put me on the right track. I created a dataflow and saved it all from cloud origination... i.e. no desktop file then publish process. When I refreshed, ran into this error. Upon seeing your comment, I went to the dataflow's settings (see image), and you were right. It changed from Organizational to Private. So I changed it back, refreshed, and we're good to go.

 

Untitled.png

 

FredLEGUEN
Helper III
Helper III

Hi group,

I have this issue today and I have solved by splitting my PQ query in 2 different queries.

I have splitted at the step when the error occurs.

And ... nothing else, no more errors

Maybe this could help other in the same situation

Hi,

Thanks for the suggestion. 

This has helped me to resolve the issue for which i wasted an entire day !

sandraf
New Member

I have created a PowerBI Desktop Model with a connection to a Sharepoint Folder.   I have been able to input the files within folder without and issue and refresh my model.

 

However I have no published to PowerBI.com and the refresh wont work.  I get the following error.

 

We cannot convert the value "[Binary]" to type Binary. Table: Data

 

Can anyone help?

 

Thanks

Sandra

Hi @sandraf,

 

Have you tried the solution provided by @Anonymous above? Does it work in your scenario? If it works, could you accept it as solution to close this thread?

 

If you still have any question on this issue, feel free to post here. Smiley Happy

 

Regards

Anonymous
Not applicable

I had a similar problem.  I ended up cheating and just converting it to TEXT, then making use of MID to check individual binary digits.  Worked fine as long as you don't need to do any binary math.

What did you convert to text? The Binary that its referring to content of the sharepoint folder and files in it.

 

If you convert that you can't then invoke the Binary function to read the files.

Anonymous
Not applicable

We might be talking about 2 different types of data.  I was referring to a data set where information was stored in binary.  This was data flags held in Active Directory, where each binary digit referred to a True/False of a given property of the record.

 

I believe you are talking about binary in terms of a File or Picture.  This won't be what I have described.

EDIT:  Made an opps.

I'm having a similar issue, so I'm wondering if this has been resolved...

 

On the Desktop, I link to a SharePoint folder that has multiple excel and csv files in it.  In the sharepoint site they are grouping in multiple folders, so it no big deal but using the method to bring them into Power BI, I have to perform some filtering steps to get the files I need to combine.  As stated prior, once I hit the Combine Files on the Desktop version it works perfectly, everything comes in and I have no issues refreshing my data.  However, once I publish to the web and try to refresh from there, so that subscribers to my report get automatically notified, I'm getting the same error message...

 

Something went wrong
There was an error when processing the data in the dataset.
Please try again later or contact support. If you contact support, please provide these details.
Data source error: We cannot convert the value "[Binary]" to type Binary.. The exception was raised by the IDbCommand interface. Table: Finance - JE Review.
Cluster URI: WABI-US-EAST2-redirect.analysis.windows.net
Activity ID: a4fdefa8-6220-48db-9c4f-adae6868a6fd
Request ID: 94d93a50-6921-59dc-227a-eded038ea081
Time: 2018-11-07 12:46:42Z

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.