Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Rakesh_Kumar
Frequent Visitor

Unable to feed on-premises SQL-Server data into Lakehouse

We are trying to write on-prem sources to Lakehouse usign dataflow Gen2. Refresh is workign fine but when it tries to write down it's thowing below error. Anyone used on-prem source with Gen2 flow. FYI we are usign latest version of Gateway:


null Error: Couldn't refresh the entity because of an issue with the mashup document MashupException.Error: Microsoft SQL: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) Details: DataSourceKind = Lakehouse;DataSourcePath = Lakehouse;Message = A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server);ErrorCode = -2146232060;Number = 53;Class = 20 GatewayObjectId: *ID*

6 REPLIES 6
Rakesh_Kumar
Frequent Visitor

we checked on this and as per MS we have to open port 1433 (SQL server port) as Lakehouse is kind of SQL server.

Rakesh_Kumar
Frequent Visitor

@v-yangliu-msft  we are facing this issue in Power BI Servcie not in local (Power BI Desktop)

gauravjaini
Frequent Visitor

facing the same problem, did you find a solution?

@gauravjaini  not as of now. We are working on it. If you find a solution please post here. 

v-yangliu-msft
Community Support
Community Support

Hi  @Rakesh_Kumar ,

 

You can try the following:

Go to “File –> Options and Settings –> Options –> Data Load and delete cache files.
Go to File -> Options and  Settings -> Data Source settings. A window with all connections you have will appear. Select the SQL connection and at the bottom of the window click edit..Update the credentials.

Ensure that SSMS is installed on the same machine with Power BI Desktop.

 

Besides, please follow the instructions in the article below to troubleshoot this connection error.

A network-related or instance-specific error occurred - SQL Server | Microsoft Learn

 

Best Regards,

Liu Yang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

It worked! Thank you so much!

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors