Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
AugustoChaves
Advocate II
Advocate II

Refreshes for Datasets containing Calculated Tables over Direct Query to AS started failing Mar 30th

Hello, 

Refreshes of datasets that contain calculated tables from DQ to AS started failing March 30th, 2022. This worked completely fine until March 29th which points to a change at Power BI service side. The error message is as follows:

 

{"error":{"code":"Premium_ASWL_Error","pbi.error":{"code":"Premium_ASWL_Error","parameters":{},"details":[{"code":"Premium_ASWL_Error_Details_Label","detail":{"type":1,"value":"Refresh is not supported for datasets with a calculated table or calculated column that depends on a table which references Analysis Services using DirectQuery."}}],"exceptionCulprit":1}}}

 

44 REPLIES 44

Odd, refreshing a report with a calculated table that references a DQ to a PBI Dataset never worked for me on the service. Now I am thinking it might be source specific since you mention this wasn't an issue for you before. 

It would fail refreshing from Power BI Service but connecting through XMLA endpoint and processing the Database it worked.

Hi @AugustoChaves ,

 

do you remember which mode you used? Process Full runs into the same error that I would get when refreshing the dataset from Power BI Service ("Refresh is not supported for datasets with a calculated table or calculated column that depends on a table which references Analysis Services using DirectQuery"). And Process Default and Recalc don't seem to update the data in the report.

 

Best regards

GSE

Nathan_C
Frequent Visitor

Hi @AugustoChaves  

Have run into the same issue with a calculated table build off of two DQ tables.  The table was being used as a data source for a paginated report hosted on PB Service.  

 

I do not have a solution for issue but have eliminated the calculated table by pulling it in as its own DQ table, and I'm no longer receiving the gateway error upon refresh.  So to me this would point the issue to being the calculated table.  I did not attempt to try creating the calculated table through an other manner within Desktop.  

 

Would appreciate if a solution is identified or the issue is resolved that you update this thread with the outcome.

 

Much Appreciated.

Hi Nathan, I have a support ticket opened and it's confirmed it's a bug/requires a fix. I'll post here when I get a response. Thanks

AugustoChaves
Advocate II
Advocate II

Hi GilbertQ, the gateway was already updated to latest version, March 2022, but that shouldn't have an impact since this is DQ to a Power BI Dataset (DQ to AS).

Thanks

Posting to keep the thread alive. 
Still facing the issue IN 2024. Any roadmap to have a resolution on this? 

Hi @AugustoChaves , any news or update from Microsoft? Did they communicate a timeline for the fix? Regards, Stijn

No timeline. Support is very poor and takes a long time to break 1st layer barrier.

I'm pressing for a date and will post here when I hear.

Hi @AugustoChaves 

 

It could possibly be that there has been a change in the underlying calculated table?

 

There are often is changes to the Power BI Service. 


What happens if you try this on PBI Desktop does it work there too (Using the latest version of PBI Desktop)?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

It seems like a chance at the service is the cause. In total 5 reports stopped working at the same time and there were no changes in any of them. I have a ticket opened but still no solution. Thanks!

GilbertQ
Super User
Super User

Hi @AugustoChaves 

 

Could you update your Gateway to see if that solves your issue?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Hello all,
just wondering was thie issue ever resolved by power bi?

i'm starting to get the issue into a couple of my reports and im just wondering if it's a ME issue or a THEM issue.

if they didn't fix what was your work around?

regards,

Ross

No work around that I am aware of yet. 

 

It doesn't even support refresh through the Gateway. 

Thankyou, 

yeah my  report dreams have been dashed this week with the gatway non refresh issue, having to think of a different approach.

cheers 

According to the official reply on my support ticket this is not an issue, it’s a feature.

I’m still owned an explanation on why it worked before and then it stopped working but I’ve given up on waiting and redesigned all reports that failed (5 or 6) from scratch.

 

Thanks Microsoft! Very clear documentation, policies and procedures.

@AugustoChaves 

Thank you for your service!  Can you please post an authoritative link to more info from Microsoft (bug number or kb number or blog or something)? 

 

I'd like to open a support ticket as well, and your prior work may save others some effort (getting thru a couple layers of support).  It is an obnoxious bug.  A report developer shouldn't be able to spend several days building something with the PBI desktop, only to find out that their report won't refresh after being published to the service.  That wasted effort is not acceptable, even by Power BI standards.

 

I suppose the official reply will include some stuff about the fact that this directquery feature is still in "public preview".  But that message is starting to seem like nonsense, considering the degree to which the functionality is promoted by community leaders, and how very long it has been in "public preview" (3 years?)

 

 

 

Hello , i have the same problem., is there a solution, on the near future?

thank you

dbeavon3
Continued Contributor
Continued Contributor

Nevermind, I found the documentation about this limitation:


https://learn.microsoft.com/en-us/power-bi/connect-data/desktop-directquery-datasets-azure-analysis-...

"Calculated tables aren't supported in the Service using this feature. Attempting to perform a refresh on a dataset with a calculated table or a calculated column that references a DirectQuery data source will result in a "Single sign-on (SSO) credential isn't provided" error message."



It still seems obnoxious that they allow you to build a report on the desktop, which is unable to be used when published to the service.  I think people would be a lot less frustrated if they weren't being "teased" with a feature on the desktop, only to find out that it isn't going to work in production.

I agree 100% with all that you mentioned. The error I am getting is not exactly as anticipated (SSO credentials):

 

"Refresh is not supported for datasets with a calculated table or calculated column that depends on a table which references Analysis Services using DirectQuery."

I support you @AugustoChaves !Posting just to keep the topic alive, as it is still a problem in 2023.

I use it to build effective dimension tables (based on data in the fact tables) with SUMMARIZE. It is also one of the things that work perfectly fine in desktop and there is no reason to suspect they wouldn't in the service until you publish and try to refresh.

 

 

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors
Top Kudoed Authors