Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Advocate III
Advocate III

Query contains unsupported function. Function name: Resource.Access

My data refreshes have been working smoothly but have been giving various issues since the weekend. The desktop refresh works fine.  I also suddenly can't see options for credentials or for the Gateway that is in place. I have been having service issues since Saturday morning when first the custom connectors failed for 24 hours, then started working again, this morning the Gateway wasn't being seen by the service then briefly came back and now I can't do any refreshes at all. I suspect its something to do with the Nov release?


I receive the following message:


You can't schedule refresh for this dataset because the following data sources currently don't support refresh:

  • Data source for Query1

Query contains unsupported function. Function name: Resource.Access

Community Support
Community Support

Hi all,


Get the latest feedback:


This issue has been deployed and validated.

PROD - 11.4 QFE –12/10 and 12/11 - Sat with US clusters- Sunday.


Best regards,

Community Support Team Selina zhu

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly



View solution in original post

Advocate I
Advocate I

Same with Athena connector...

Regular Visitor

We have the same issue. Did anyone solve it?

Advocate I
Advocate I

Similar issue from my side! But I know it comes from my Python script...
Even if the refresh is working on Desktop but not when I want to do it on Power Bi online.


they say "Power BI customers trying to configure credentials for datasets using Gateway may see the following error message "Query contains unsupported function. Function name: Resource.Access". Engineers have identified the root cause and a fix is expected to be deployed by end-of-day 12/11/2022."

AWESOME! Thanks for the news. 

Hi all! Please promote this issue. It is without a doubt some change in the Power BI/Power BI Gateway (Personal Mode) service. Some Azure clusters stop working before others, mine located in WABI-SOUTH-CENTRAL-US, stopped in '2022-11-25T15:42:07.0000000Z'. If someone has already opened a case with Microsoft, please share the link.

Hang in there!

Same problem here too. Pbix refresh works fine, but service refresh dosen't.

I am using MariaDB connector and it shows me this:



I just had a call with Microsoft. The product group is aware of the issue and are working on a fix.
Will let you guys know once I get an update.

latest update from Microsoft:

Product group just mentioned the fix is prepared and is being checked and validated to ensure it will work as intended. After that it might take few days to be deployed to all clusters. It is most concrete information we have currently so I believe it will not take too much time but still I cannot give you exact ETA for deployment as PG did not give us any.

Thanks for the info. Awaiting the solution!!

thanks! I'm waiting for it 🙂

Regular Visitor

I'm also having the same issue

Advocate II
Advocate II

I have also raised a ticket, as I am experiencing the same issue. 

Advocate III
Advocate III

I have raised an incident with Microsoft to get some attention!

Had a call with MS. They are aware of the issue as many people reported already. They work on it on priority but there's no ETA as of now. 

me too.. I will let you know if I get any news.

Helper I
Helper I

I'm also having the same issue while my Database is hosted on MariDB. gateway for maria db working fine. Data Refresh on PBI Desktop is fine but creates problem on Services.error.PNG

Advocate I
Advocate I

Same issue with Denodo Connector. It's been failing since Friday. Any updates from Microsoft? 

Frequent Visitor

Same issue here, also working with custom connector from Davista, Google Sheets and Odata feed.
Problem started this weekend before everything worked fine, even removed on a backup all my changes from last week to an earlier version and that one now gives the same error


Frequent Visitor

We're also experiencing this issue.
Custom directquery connector refresh failing through gateway with message

"Query contains unsupported function. Function name: Resource.Access"


Advocate I
Advocate I

I have the same issue!!! I use MariaDB and GoogleBigQuery. My file works and refreshes fine on a PBI desktop. The problem is only on the PBI service.

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.