Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Frequent Visitor

PowerBI Source Control lists more files than in the workspace

After integrating the source control feature into my workspace, I see files in version control that are not present in the workspace.To me it looks like version control lists some old deleted objects.

Is there a hidden function to see all objects in a workspace, for example in the group storage area?


Frequent Visitor

Hi @v-tangjie-msft,


the repository is empty and I asume that the issue is not releated to the source control.
The strange thing is, that I can find the the items in the global search. When  I click on the those items I get an infinitif loading. But I can see the group and report id in the url. When I try to delete the report via the api then I get an success measage and and the report disapears in the source controll list. Could it be, that the source control lists the report with a different scope then the workspace view?

Frequent Visitor

Hello @v-tangjie-msft 


it seems that the issue isn't related to the source control and my repos is empty and the problem occures before the sync prozess.

I can find the items in the service via the global search.

When I click on a search result, the service trys to open the report and ends in an infinitiv loading. In the url I can see the related workspace and report id.

When I search for workspace and report id via the rest ip, I getting an error, that the entity not exists. But when I try to delte the report, then I get a 200 status code. And the report dosen't occurs in the source controll. 

Seems that there is something messed up in the internal storage for datasets and reports in this workspace.

Additional info: not existing datasets, they are displayed in the source control, are not listed in the search result. 



Hi @chrissto ,


If you are a Power BI Pro licensee, you can create a support ticket for free and a dedicated Microsoft engineer will come to solve the problem for you.
It would be great if you continue to share in this issue to help others with similar problems after you know the root cause or solution.


The link of Power BI Support: Support | Microsoft Power BI

For how to create a support ticket, please refer to How to create a support ticket in Power BI - Microsoft Power BI Community


Best Regards,

Neeko Tang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly. 

Community Support
Community Support

Hi @chrissto ,


There are a few possible ways to do that:

1.You can use the Power BI Helper tool to connect to your Power BI account and document all the objects in your tenant, such as workspaces, reports, datasets, dataflows, and more. You can also export the documentation to Excel or PDF files.

2.You can use the Power BI REST API to programmatically access and manage all the objects in your workspaces, such as getting a list of workspaces, reports, datasets, dataflows, and more. You can also perform actions such as creating, updating, deleting, cloning, or restoring objects.


Best Regards,

Neeko Tang

If this post  helps, then please consider Accept it as the solution  to help the other members find it more quickly. 

Hi @v-tangjie-msft,


Thanks for your replie. I tried to list the reports and datasets via the reset api and I get the same items as I see in the workspace and can't see the additional items they are listed in source control.


I also tried to undo changes in source control and I got a message that the particular dataset and the related dataset is not existing.


How do source control detect those times they obviously dosen't exists in the workspace?

It would be really cool to have source controll integration and a proper deployment process.


Hope you have some idea how to solve this issue.


Thanks in advanced,

Hi @chrissto ,


This can happen if the files were deleted or moved but their history is still present in the source control system.

To resolve this issue, you can try the following steps:

Verify the files in your source control system: Check the history of the files in your source control system (e.g., Git) to see if they were deleted or moved.

Synchronize your workspace with the source control system: Make sure your workspace is up-to-date with the latest changes from the source control system. You can use the "pull" or "fetch" commands in your source control system to update your workspace with the latest changes.

Resolve any conflicts or issues: If there are conflicts or issues between your workspace and the source control system, you may need to resolve them manually. This can involve merging changes, resolving conflicts, or reverting changes that caused issues.

Commit and push your changes: Once you have resolved any issues and your workspace is up-to-date, you can commit your changes and push them to the source control system. This will ensure that your workspace and the source control system are in sync.


You can refer to the following documents that may be helpful to you:

Introducing git integration in Microsoft Fabric for seamless source control management 

General | pbi-tools

azure-docs/articles/synapse-analytics/cicd/ at main · MicrosoftDocs/azure-docs · Gi...

azure-docs/articles/data-factory/ at main · MicrosoftDocs/azure-docs · GitHub


Best Regards,

Neeko Tang

If this post  helps, then please consider Accept it as the solution  to help the other members find it more quickly. 

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.