Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
ChristianEvan33
Frequent Visitor

Failed to update data source credentials: The credentials provided for the OData source are invalid.

Currently I have an issue with Refreshing the dataset that I uploaded to the Power BI web service.

Please note that it works and able to refresh the data totally fine in Power BI Desktop.

The issue is in the data source connected to Odata Feed 

Pic 3.png

 

 

 

 

 

 



I wanted to get all of my Microsoft Planner task data with this method, and based on a few reference requires me to use Microsoft Graph Explorer. 

I am utilizing my organization account and have a Power BI pro license. The following error message is returned when attempting to refresh in Power BI service:


Pic 1.png

 






I attempted to re-establish the credentials but the same error persisted. Other sources such as SharePoint and dataflow do not exhibit any issues and refresh properly. The error only surfaces from the Odata Feed connection where I utilized Microsoft Graph Explorer to retrieve the task data in Microsoft Planner.


Pic 2.png

I tried connecting the data source (OData Feed) to a Power BI dataflow, also returns the same error.

 

Any assistance would be highly appreciated, as I have spent the entire day trying to resolve this issue without any progress.

 

 

24 REPLIES 24

I had this issues before and I noted what I did to resolve it above. 
However more recently I had the issue on another file and I logged in locally in transform data and edit credentials and all was good. 
In the cloud it kept giving me the error in our Test workspace. 

I deleted the file from test and pushed it again from Dev and BOOM! All good. 

 

Looks like Power BI kept it in the cache or something. 

 

Rick

Did you try to get data from azureAD?

Also as a test you can copy your file, save the name with - Temp or whatever you want at the end. Push to the same workspace and then go into settings and credentials, see if any need update, click to update. Try refresh, if it works, most likely PBI is holding creds in cache.

Data was using my AD creds to get data from Databricks. 

I want to get data from AzureAD(Entra)

Yurii-Chahovets
New Member

Any updates?? PowerBI team what do you think? Why it works in the PowerBI desktop but doesn't work in online

YuriiChahovets_0-1702928716263.png

 

Denis_Diakov
Regular Visitor

I have the same problem. Authentication on my power bi desktop works correctly, but when using power bi services, it shows a failure message: 'The credentials provided for the OData source are invalid.' I'm retrieving data from Planner. I've been reading a lot of posts, but I couldn't find a solution.

I hope that you have already found one. What was your resolution?

@Denis_Diakov 

I'm useing company account.

Use www.powerbi.com

Go to workspace

Choose that datset, check "Settings" --> "Data source Credentials"

Choose "OAuth2", pricvacy set at "Organizational".

Hope this helps.

Hey 

 

just want to thank you from all my heart you saved my day. thank A ton.

Tom_Y
Helper III
Helper III

I have the same problem. Not OData, but an excel file in Sharepoint. It refresh perfectly on Desktop but once I publish it Workplaces in Power BI Services it fails to refresh.

I have made sure that the credentials are correct (same for organization log-in, power bi desktop, etc).

I have tried both "web import" and "sharepoint folder", same failure.

 

Data source errorThe credentials provided for the Web source are invalid. (Source at https://company_name.sharepoint.com/sites/Projects/Shared%20Documents/file_name.xlsx.). The exception was raised by the IDbCommand interface. 

KenEddie
New Member

I'm getting the same issue too, have setup my connections to Graph in the Power BI desktop app to get an update of my Planner tasks. I can refresh the dashboard via the desktop app but can't get it to refresh via the Power BI web app so that its auto refreshes daily. I am using the same UPN/credentials in desktop and Web. 



Glad I saw this post and was not the only one with the issues. 

My fix - 

In Power BI desktop, I hit transform data.
Then I hit Data Source Settings (top left).

Then on the bottom of the window that opens, I hit "Edit permissions". 

Updated the login. 

Hit close. 

Close and Apply (top left). 

Hit refresh. 

Saved and published to my development workspace. 

Then tried refresh and it all wen fine. 

Used the pipeline and pushed to Test and then Production. 

 

Hope that helps! 

 

Rick

v-yueyunzh-msft
Community Support
Community Support

Hi, @ChristianEvan33 

According to your problem description, it is successful in Desktop, I think since you encountered the error message related to "Invalid credential", the problem is still related to the credential cache of Odata data source on the service of your account, you can go to the "Manage gateway and datasource" page, find the data source definition of Odata data source, and click Delete.

vyueyunzhmsft_0-1678441106036.png

After that, you go to the dataset setting interface, click edit credential to re-enter Odata's data source credentials for the dataset, and check whether you can successfully configure the data source credential connection.

 

Thank you for your time and sharing, and thank you for your support and understanding of PowerBI! 

 

Best Regards,

Aniya Zhang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

v-yueyunzh-msft
Community Support
Community Support

Hi , @ChristianEvan33 

According to your screenshot , it works well in the Power Bi Desktop, but in Power BI Service, it seems the credential you provide is not right.

You need to go the Power Bi Desktop , and click "Transfor data"->"Data source settings" to see which credential you provide in Power BI Desktop:

vyueyunzhmsft_0-1678243476356.png

vyueyunzhmsft_1-1678243532453.png

You need to keep the same both in Power BI Desktop and Power BI Service. By default , the "Ouath2" is using the Azure Active Directory(AAD) as a credential , if your datasouce is not used AAD as an autentication mode , you need to change the autentication mode in Power Bi Service.

 

Thank you for your time and sharing, and thank you for your support and understanding of PowerBI! 

 

Best Regards,

Aniya Zhang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

I was having the same refresh problem because of invalid credentials process. What worked for me was using a local gateway instead of a cloud connection. 

Mateus_dadalt_0-1699968361714.png

 

Anonymous
Not applicable

Hi @v-yueyunzh-msft,

 

Could you please tell me how can we change the authentication mode in Power Bi Service?

 

Hi , @Anonymous 

If you need to change the authentication mode in Power Bi Service, you can fo to the setting of the dataset and then click "Data source credential" .

vyueyunzhmsft_0-1678326915855.png

And if you actually need use the "OAuth2" , you need to click "Sign in" and login in a user who has the permission for this api.

 

Thank you for your time and sharing, and thank you for your support and understanding of PowerBI! 

 

Best Regards,

Aniya Zhang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

 

Thank you for your response. To clarify, does this mean that my user account requires either global admin rights or specific API permissions through Azure Active Directory (AAD)?

 

Is this permission only necessary when refreshing data within the Power BI Service (Cloud)? I ask because I am able to refresh data from Microsoft Planner using the same organizational account in Power BI Desktop.

 

Additionally, in Power BI Desktop there is no option to select “Oauth2” as an authentication method. Instead, I simply log in with my Organizational Account. Is this expected behavior?

Hi , @ChristianEvan33 

The credentials you set is used for this data source instead of the user login on .

We need to configure this data source with credentials that are accessed by permissions.In Power BI Service and Power BI Desktop, we all need to configure the corresponding credentials for the data source. Credentials are needed when we request access to the data source, and refreshing also requires access to the data source, so credentials are also required.

To test , you can first try to make the same credential has been configureed both in Desktop and Service.

 

Thank you for your time and sharing, and thank you for your support and understanding of PowerBI! 

 

Best Regards,

Aniya Zhang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

I have already updated the credentials in Power BI Service to match those used in Power BI Desktop. As such, both sets of credentials are now identical.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.