Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Memorable Member
Memorable Member

Error accessing PPU workspace General properties using SSMS

Using SQL Server Management Studio (SSMS), I am able to connect to my Premium-Per-User (PPU) workspace. However I want to review and edit the timeout settings, which are on the General tab of the workspace Properties dialog.


I always get this error when I choose the General tab:


The Analysis Services server administrator role is not supported in Power BI. Please use the Power BI security model instead.


I am trying to follow the advice from this blog post:

Memorable Member
Memorable Member

Actually, for PPU there is nothing shown in the Power BI Admin Portal under Capacity Settings. That only shows Premium Capacity. 



Please refer this post-

Power BI - Granular control with Analysis Services server properties


I hope it will be helpful.



Solution Sage
Solution Sage

Hi, @mike_honey 

You can manage your PPU capacity in the admin portal of Power BI Service, as shown in the following figure:




You can connect to your semantic model through Power BI desktop by going to File > Options and Settings > Data Source Settings, where you can modify the data source settings, including the timeout‘’


If you need to adjust advanced settings such as timeouts, consider using PowerShell scripts or the XMLA endpoint. The XMLA endpoint allows for advanced configuration and management of datasets in Power BI.



Did I answer your question? If yes, pls mark my post as a solution and appreciate your Kudos !


Thank you~

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.