Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Anonymous
Not applicable

Error : The connection you are trying to use has not been shared with you on the on-premises data

Hi Everyone,

 

I am trying to establish the "Dataflow" to enable "Selfservice BI" for the users in the "Power BI Service" by using an "ODBC" as a data source by providing below details and getting the error stating that "The connection you are trying to use has not been shared with you on the on-premises data gateway. (Session ID: 39357edc-1e19-4b26-a017-c2ed63a3ac8f)".

Below is the screenshot information for your easy reference.

hemanthgb_0-1615203409924.png

 

 

 

We have even tried to select other drop down values i.e "Basic" & "Windows" [With proper credential details] under an " Authentication kind" tab and still error is remains the same.

 

Note :  Admins are able to connect but users are not able to connect though have same permissions.

 

Any suggestions/inputs/solutions on this scenario would be highly appreicated.

 

Kind Regards,

Hemanth

 

 

 

 

 

1 ACCEPTED SOLUTION
v-kkf-msft
Community Support
Community Support

Hi @Anonymous ,

I have reproduced your question. You need to confirm that the data source has been added to the gateway you are using. Then you should be the administrator of the gateway and you have been added to the Users of the data source.

1. Select Settings > Manage gateways. Add users as gateway administrators.

v-kkf-msft_0-1615359225218.jpeg

2. Add the data source to the gateway.

v-kkf-msft_1-1615359317028.png

3. Add users to Users of the data source.

v-kkf-msft_2-1615359345601.jpeg

4. Connect Odbc.

image.png

If the problem is still not resolved, please provide detailed error information or the expected result you expect. Let me know immediately, looking forward to your reply.

Best Regards,
Winniz

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
alex15
Frequent Visitor

Hi,

I do not understand why should the user be admin of the gateway? That is not the case for data sources and I do not understand the logic.

 

We want to open the connection to our data analysts to create data flows but not to create new connections on the gateway.

 

Salut,

Àlex.

PreetMDX
Frequent Visitor

Hi, I'm facing the same issue, added as a user on the gateway.

I'm able to use the gateway in existing dataflows but when creating one system is throwing the following error:

 

"The connection you are trying to use has not been shared with you on the on-premises data gateway".

venkatnitt84
Frequent Visitor

Hi - Were you able to fix this issue. I am having similar issue.

v-kkf-msft
Community Support
Community Support

Hi @Anonymous ,

I have reproduced your question. You need to confirm that the data source has been added to the gateway you are using. Then you should be the administrator of the gateway and you have been added to the Users of the data source.

1. Select Settings > Manage gateways. Add users as gateway administrators.

v-kkf-msft_0-1615359225218.jpeg

2. Add the data source to the gateway.

v-kkf-msft_1-1615359317028.png

3. Add users to Users of the data source.

v-kkf-msft_2-1615359345601.jpeg

4. Connect Odbc.

image.png

If the problem is still not resolved, please provide detailed error information or the expected result you expect. Let me know immediately, looking forward to your reply.

Best Regards,
Winniz

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.