Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Frequent Visitor

Deployment Pipelines - Dataset is different after a "Successful" Promotion from DEV to TEST



We have been using Deployment Pipelines fairly successfully for 2 months now and working through issues. We need some ideas on how to best troubleshoot what is causing the dataset to be different, after a successful deployment from DEV to TEST. 


What we did:

1. Downloaded Power BI Desktop Oct 2020 version

2. Implemented RLS into our dataset

3. Published "Sales" PBIX file into Deployment Pipeline DEV workspace

4. Had an administrator "Take Over" dataset ownership from publisher developer, made sure credentials to our 1 data source was valid and refreshed dataset successfully

5. In Deployment Pipelines interface, Administrator selected "Sales" report and dataset from DEV and promoted to TEST workspace "Successfully", however after deployment, the dataset was not equivalent, but the report was. 

6. While troubleshooting, we had our BI "Sales" report developer rename the "Sales" report to "Sales_Test" and do the deployment of the report and dataset together from DEV to TEST, and the dataset was equivalent. 


We dont want the Developer doing the deployments, so do you have any troubleshooting ideas on why things are different?





We are not using any of the following Unsupported items:

Unsupported items

Deployment pipelines doesn't support the following items:

  • Datasets that do not originate from a .pbix

  • Reports based on unsupported datasets

  • Template app workspaces

  • Paginated reports

  • Dataflows

  • PUSH datasets

  • Workbooks







Hi @apratt2003 , 
The release for GOV sites takes a bit longer and so it is expected to be released by end of January.
Thank you,


I can confirm that our GOV site is now functioning correctly.  Thank you.

Ok, thank you for the response.

Anyone expereincing this deployment pipeline issue again?  I just promoted from DEV to TEST and its showing differences, even though there are none. 


I published a dataset to DEV using PBI desktop and then used deployment pipeline to deploy to TEST and it says differences.

I am having same issue.  I just setup a new Deployment Pipeline..

I published three datasets to the [Test] stage. then deployed the datasets and their associated reports to [Production].  Two out of three datasets compare as equal, but one does not.  Can't be because of any changes as all I did was publish to [Test] then straightaway publish to [Production]...

So the issue resolved itself... I turned off the scheduled refreshes.. then used the REST API calls to cancel any outstanding refreshes.  In our case it seems things got messed up when more than one refresh was executing or attempting to execute.  I turned off the scheduled refreshes for about an hour or two then turned them back on.  and within the next hour the scheduled refreshes started working...

I did experience the same issue again too last week.
It went away, when I let the dataset fully refresh first in DEV before promoting it to TEST and PROD. 
Interestingly it never showed a difference between TEST and PROD, no matter what the refresh status was.
Maybe this helps.

Hi @wjkolesar,

In some (not so common) cases the comparison process of an item cannot be completed so its sync status is unknown. Deployment pipeline tagged such items as 'Different'. You can open a ticket for support to check whether it is this case or other and get further assitance. 
In addition, we're about to release a new feature in a few weeks, which provides more details on the 'Different' label: name change, schema change (with the option to view the changed lines highlighted in the schema) or unknown (the above scenario). At first, the supported item types are just dataset and dataflow, we'll soon have paginated report and we hope to quicky add other textual item types. stay tuned! 



No, My pipeline is acting as expected.

New Member

Hello I have exactly the same issue now. 


After deployment process from dev to test piepline shows the datasets are different. What's more if the dataset is published directly to the PROD then after deployment from Test to PROD we have 2 datasets with the same name.


I've already remove all datasets from DEV and TEST workspaces and try to deloy everything once again, but it still not working. 


Any idea what can I do?

Super User
Super User

I've had a similar issue and after a bit of testing, I've found a workaround for my scenario. Posting here in case it helps others.


The change that broke it

My dataset is separate from my report.

Deployment pipelines were previously working without issue.

The only change I made was to rename the only security role in the dataset and deploy to dev.


Confirming the issue

To check that my assumption was correct, I changed the name of the security role back to what it was and redeployed to dev. Deployment pipelines worked again.


The workaround

I needed the security role renamed so to try and get dev and test to align, I deployed my PBIX with the renamed security role back to dev and then also manually deployed my PBIX directly to test. No need to delete first.

Pipelines now works again. 


Like I say, might not be suitable for all cases, but hopefully it is helpful to some.


Have I solved your problem?
Please click Accept as Solution so I don't keep coming back to this post, oh yeah, others may find it useful also ;).

If you found this post helpful, please give Kudos.
It gives me a sense of instant gratification and, if you give me Kudos enough times, magical unicorns will appear on your screen.
If you find my signature vaguely amusing, please give Kudos.
Proud to be a Super User!PBI-Super-User-Rank-30x30-1x
Post Patron
Post Patron


@perdigao18  do you have any updates? It seems that I am experiencing similar issue.

@Nimrod_Shalit  any known issues from Microsoft regarding this case?




I stopped to have this strange behavior after separating dataset and report in two different .pbix files as recommended in the good practices of deployment pipelines:

To split it, check the following link :

With that, the changes done in the report or in the dataset become more independent what is better for deployment. 

I hope it can help, 

New Member

Thank you for this update. I see the same as @Kwarren35, I first noticed this after the upgrade from the Sept to the Oct build.

Power BI Team
Power BI Team


Few questions to better understand:

1. did you configure rules on the 'Sales' dataset? if so, were they already applied?

2. when you said 'different', did you mean that they were labeled as 'different', or you actually spotted a difference between the datasets?


1. The BI developer applied the Role Level Security rules to the dataset before publishing to DEV workspace.

2. The deployment pipelines interface shows the "sales" dataset as non-equivalent between DEV and TEST, but I cannot spot a differences when comparing files

Hi @Kwarren35 !

Sorry to hear about that.

We have a bug in that area, working on fix right now.



Hello. I think I have the same error here. There is already a fix ? 
If in dev I make an update that changes my dataset, when deployed to test it will keep saying that there is differences between the two datasets. Then, if I download the dataset .pbix from the test workspace, i can see that is is all messed up (tables names and fields) . I can only get this ok if I delete everything from test and deploy again from the beginning what is not good. 

There is any solution ? 

@perdigao18 , few questions:

  • Is it happening on other items in your pipeline, or just datasets?
  • Is it happening on other datasets, or just this particular one?
  • Did it happen several times on that dataset, or just once?
  • What change did you made, that caused it to happen? or any change ends up with same result.

Also note that downloading a PBIX that been created/ updated through deployment isn't supported, so you might get corrupted files. We will block the option to download in the near future.

Hello , 
For now I am just working with a single dataset that feed a report. So, it is just happening to  the dataset, what has then an effect in the report. 
It was more than one time and to fix it I had to delete the content of the workspace and deploy again. 
The changes that I made that lead to this were changes in the model in PowerQuery. One time was the adding of a new table and the other time was the change on a step in a query. 
How I manage the process : I made the changes in the PowerBi desktop and then I publish to the dev workspace, overwriting the existing content. Automatically the comparison in the deployment pipeline detects that there are differences in both objects : report and dataset. I select both and deploy to test environment. Then no differences are detected between the report, but the dataset still detects differences. When I said that I download the .pbix is not from the deployment is from the test workspace view. 

I am not saying that it happens everytime I did changes in the model, but at least in these times it happen. 

Thanks a lot.

Please open a support ticket, sounds like a specific bug.

Add screenshots and the details of all the relevant items, so we can track down the problem.



Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.


Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.