Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Anonymous
Not applicable

Users getting error when accessing reports

Hi All,

 

I am having some issues with users accessing reports that have been made that I'm hoping someone may have encountered or have an idea on what is going on.

 

My organisation has a large number of reports within power bi which we control access through using user groups.  These reports are for internal and external customers.  Internal customers can see everything whilst external can only see certain ones.  To make it easier for our internal customers to see what is available we have created an access point which has our branding and lays out our reports into certain groups.  To access the reports we have buttons that use the URL of the report to redirect the user.

 

What we are finding is that some people are getting error messages saying 

Unable to navigate to destination - this page may not exist of may not be a valid destination  or

Sorry, we couldn't find that report - it may have been deleted or you may not have access to view it.

 

Everyone has the same level of access to the reports but these errors come up on random ones for random users.  I've checked permissions, links etc and everythign is as it should be.  If a user trys to access the report using the URL they can get in without issue (we have had one user who got in via the URL but then got locked out of the access point).

 

Does anyone have any idea what might be going on here?

1 ACCEPTED SOLUTION
ray_ux
Memorable Member
Memorable Member

@Anonymous sounds like a cache issue or report name /location were changed from the original. I would try to create a fresh url share link and replace all the existing ones, if they still have the same problem then they need to clear cache.

View solution in original post

2 REPLIES 2
Anonymous
Not applicable

Fantastic, I'll give that a go and hopefully fixes the issue.

ray_ux
Memorable Member
Memorable Member

@Anonymous sounds like a cache issue or report name /location were changed from the original. I would try to create a fresh url share link and replace all the existing ones, if they still have the same problem then they need to clear cache.

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.