Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Frequent Visitor

Export data doesn't work with PBI RS March2018 (on-prem)

I've upgraded our test environment with the latest release of PBI RS (March2018).  All our reports appear to load, and mostly function as expected.  However, clicking on "Export Data" from any visualization on any report does absolutely nothing.


Here's what i've done to troubleshoot so far....


1. Confirmed that production (still Oct2017 version) still exports correctly, which it does  

2. Rebooted server and my pc

3. Cleared my browser cache

4. Deployed a brand new report to PBI RS with the new PBI Desktop RS... still nothing.


Anyone else experiencing this?  Any suggestions?

Re-deploy all our reports using the new PBI Desktop for RS?


I'm really hoping this is something dumb on my end and not a bug that MS missed, or worse.... a new "feature".  







Is there a solution for this please?  I have a larger data set via a straight table visual. It won't import from IE with a "Long Script" error returned.  it works fine in Chrome.  Majority of our business users are on IE11 so I need a fix for IE11

Yes the export data issue is fixed in this build, if it's not working you can try to refresh your browser cache which may resolve the issue.

Not applicable

I have tried refreshing the cache and the issue still persists. is there a different configuration setting that we should try? 

Normally not. Are you sure that you are using the standard config file without any changes? Try the export with a small dataset behind. It does take some time if there is a lot of data behind a visual.

Not applicable

Thanks, but no, we're looking at tiny datasets here - 50 rows tops.


It works as designed on the desktop version but not on the on prem PBIRS site.


I'm very frustrated by this. Especially with the destructive upgrade on the database side, its not just as simple as rolling back to the October release.

Not applicable

I do have the same issue. I have just installed version of the server, but the export ist not working. The Power BI dashboard I am testing uses a table visual. But it also does not work with a matrix visual. I have tested with a Direct Connection to a Tabular Model as well as a dataset from a csv-file (20 rows). I have also restarted the Power BI Server as well as the whole machine. And I have cleared the caches of both browsers I am testing with (IE 11 and Firefix 59.0.2).


Help is greatly appreciated 🙂


Kind regards


Not applicable

Very interesting: I have just installed version  on another server (with no prio Power BI Server version installed). And the CSV export is now working with this installation. However, it is still not working on the other server where I upgraded from a previous March version to a newer version.


Kind regards


Thank you very much for the new version. Export data is working with this one.

were you able to find the download link?

I don't find it either...

Hi mgmeyer,


Do you have an update on this fix? Or is the rollback scenario supported to the october 2017 version?


A fix for this bug is great news.  Please don't forget about the other bugs found in the March 2018 release too.  URL Parameters not working is a serious issue in this release too (Community Issues Forum Link).

By the way what are the official channels for getting the PBIRS updates?

I keep on checking timestamps on

and generally

Helpful resources

Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City


Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.