Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
eddydm
Advocate II
Advocate II

Monitor PowerBI Gateway: wrong export?

Hi,

I have installed the powerBI on-premises data gateway (May 2010(release 2)). In this version you can export data aboud duration of queries to monitor the datagateway. Those exported data has to be reachable for a (by Microsoft) built pbit-templace.

My problem is that we are used to write numbers with a decimal comma, not a decimal point. The exported data contains ,symbols as seperator between fields.

How can we configure the gateway so that for the monitoring-export-data he has to use another delimiter? 

 

At this moment I copy the monitor-export-data to another location and then I manually adapt the ,00, to , (I'm so happy that the exported data doesn't contains symbols after the decimal symbol). Then the import is OK.

 

Thanks in advance for any ideas?

 

 

 

6 REPLIES 6
v-piga-msft
Resident Rockstar
Resident Rockstar

Hi @eddydm ,

I'm afraid that may be affected by region setting for your device system.

Please try to change the region setting like below.

Capture.PNG

 

Best Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks for the idea, but I still see a problem.

 

In our configuration the symbol ; is used as list separator, but the gateway-service makes exportfiles with , as separator. The problem is that , is used as decimal delimiter (as configured in the server-settings), but also as list-separator.

 

If the list-separator would be changed in the export, we could adapt the .pbit-file and solve the problem.

 

Hi @eddydm ,

Have you solved your problem?

If you have solved, please always accept the replies making sense as solution to your question so that people who may have the same question can get the solution directly.

If you still need help, please feel free to ask.

Best Regards,

Cherry

 

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I don't have a solution (except manually copy the file to another location and manually adapt the content).

 

The monitor (of the export-functionality) use the the decimal separator defined in the configuration-settings of the server, but doesn't use the field-separator defined in that same screen.

The only real solution I can see is that the  export-functionality is adapted.

 

 

A colleque received yesterday a message from Arthi Ramasubramanian Iyer that the issue of using server-configuration-settings will be fixed with the June release of the gateway.

Attention: I had to reinstall the data gateway and lost my changes in Microsoft.PowerBI.DataMovement.Pipeline.GatewayCore.dll.config and the existing reports

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors
Top Kudoed Authors