Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
ancasselman
Frequent Visitor

GA4 Connector - Not finding all GA4 properties

I have installed the July 2023 update for PBI and trying to use the revised GA connector to get GA4 data.  When i choose the Beta 2.0 implementation, I can see a couple of my GA4 properties, but some are not there.  

I tried also using the 1.0 implementation, and when I do that I can see the GA4 properties I'm looking for in the list, but i can't expand the list to select dimensions and measures. (I do not expect the 1.0 implementation to work for GA4 properties, just pointing out that it's interesting that i can see some there that don't show up in the Beta 2.0)

 

Is there something in particular about the GA4 property setup that needs to allow PBI to find it? Or is this a bug with the new GA Connector implementation?

3 REPLIES 3
ReportGuru
Helper III
Helper III

Hi @ancasselman Seems like the 2.0 beta connector is still presenting some issues. As a workaround, maybe you can try to test your connection with a 3rd party tool. I've tried windsor.ai, supemetrics (which doesn't have PBI as a destination, so you first have to export to Google Sheets and then export to PBI) and funnel.io. I stayed with windsor because it is much cheaper so just to let you know other options. In case you wonder, to make the connection first search for the GA4 connector in the data sources list:

 

GA4-1.png

 

After that, just grant access to your GA4 account using your credentials, then on preview and destination page you will see a preview of your G4 fields:

 

GA4-2.png

 

There just select the fields you need. Finally, just select PBI as your data destination and finally just copy and paste the url on PBI --> Get Data --> Web --> Paste the url. 

 

SELECT_DESTINATION_NEW.png

IngaRi
Frequent Visitor

So, in our case, it appeared that we were unable to see the GA4 property in PBI because it was created under a new GA account (different from the one with UA properties, we had had access to both accounts). After the client moved GA4 to their original Google Analytics account, GA4 data became accessible in the Beta 2.0 implementation.

IngaRi
Frequent Visitor

I'm having the same issue: some GA4 accounts are not visible in = GoogleAnalytics.Accounts([Implementation="2.0"]) but are visible in = GoogleAnalytics.Accounts(), thogh data tables are empty. 

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors