Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Community Champion
Community Champion

Expression.Error: The key did not match any rows in the table

I have a data set that has refreshed successfully in the past. It was built 3 days ago and refreshed fine for two days. Now I cannot refresh it either on the desktop version or from services. The error reads Expression.Error: The key didn't match any rows int he table. Other tables return the error message Load was cancelled by an error in loading a previous table. I tried to delete the problematic table from the data set with plans to re add it later. When I deleted the problem table, a second table threw the same error. I removed it too and a third then erred.  It is a domino effect. All tables are failing one at a time. The tables, however, are fine. I can use them in other documents and in PowerPivot. any ideas?

A coworker updated her version and the gateway and is getting the same error. This was built in a group and resides in the group folder.

Did I answer your question? Mark my post as a solution!

Proud to be a Super User!

Advocate II
Advocate II

Ran into this issue myself within the Power BI Desktop and was able to resolve the issue through the following:


  1. Select Edit Queries from the menu to open the Query Editor
  2. Use the left hand menu to select one of the queries having the issue (will have the triangular warning sign)
  3. On the applied steps menu at the right select the source step.
  4. In the top menu bar, select Refresh Preview.

In my case there were several queries having this same issues and the steps above resolved each of them.


Hope this helps -

View solution in original post


I have encountered the error "Expression.Error: The key did not match any rows in the table" when importing data from smartsheet to Power BI. The simplest approach would be - you may need to adjust the source key in the query.


a) To do this, go to the 'Advanced Editor' option and find the line that starts with 'Source ='. Replace the existing key with the one that matches your smartsheet data. You can find your data key in the smartsheet URL. For example, if your URL is, then your data key is '2760106596847492'.

After changing the source key, delete any unnecessary steps (in my case mismatched key step) and click 'Close and Apply' to load your data.


By following these steps, my problem was solved! 


I have also met up with same error, when i reviewed data sources and applied steps again carefully the error was gone.



No help at all.


I've deleted my query and rebuilt it. Before I've made any changes to the data I'm getting this error and the data refuses to load where it did before. What the frog is going on?

Not applicable



Tengo el mismo problema. Estoy trabajando con BigQuery que agrupa muchas sheet de google. Puedo trabajar bien en la version escritorio se actualiza bien, pero al actualizar en la web me genera este error. 

Ayuda por favor!

My error still persists, I'm using a source as an import in Google big query, I even separated each table in a pbix file to update, but the error happens in all files, I don't know what to do.

Helper II
Helper II

I have the same problem in Power Query through Excel 2016 too. None of the suggestions in the thread worked for me, unfortunately.

Not applicable

Just to add to the growing responses on this error. 

I have resolved this by using Basic Authentication on the Gateway, rather than Windows. This despite desktop using Windows.


I'm not fully certain how making this change has worked, given some of my Impala datasources were able to refresh on the Server with Windows, but not others.


We re-entered the credentials to the Gateway on Windows authentication and it threw a connection error, upon changing it to Basic it connected and I can now refresh from all Databases the account has access to. 

Hope this helps others. 

Not applicable

I had this same issue.  Turns out when I changed some code I was dropping the source table instead of a temp table used in the query.  So, it the source is unavailable it would appear that will also cause this error.

Advocate I
Advocate I

I had this same issue and in my case it turned out to be permissions on the SQL views. As soon as I added the correct permissions to the views using SQL management studio - BOOM - worked fine.

Frequent Visitor

Hi All,

I'm connecting to a data source on SQL server and faced the same "key didn't match" issue. tried all suggestions from community and almost anything from net, but none has worked for me. 


After 7 hours of research and trial and error, I discovered something related to my credential on SQL server that was causing this issue.  I'm not sure why the "db_owner" was unticked!(might be due to the patching updates on the server) I checked the box then refreshed the report and now it is working as normal. 

 PowerBI The Key did not match Solution.JPGIn SQL management Studio, navigate to the Databases\[database name]\Security\Users\ and double click on the userID to open the "Database User" window, then select the "membership" from the left side of the window.


I am the dabase owner so the db_owner is ticked, if you are not an owner, then make sure that at least the "db_datareader" is checked.

Hoping it helps you to save heaps of troubleshooting time.




Thanks a lot! it did help me

I just wanted to thank you for your post.  It helped me solve my issue.


I have my gateway configured to use a specific user on my SQL Server database.  This user did not have db_owner set.  Once I set that, my refreshes started working fine.  I was thrown off bc the refreshes were working from Power BI Desktop but not in the Service.


Of course, these errors are so cryptic, you could spend a whole week trying to figure out what the heck they mean.


Anyhow, you saved me a lot of time and I thank you.



Good to hear that it helped you to resolve the issue 🙂

Not applicable


My datasource is google analytics, I'm getting same error.

From last 2 months query working fine but all of sudden this error pop up.

Anybody have any Idea what can I do.


Thanks in advance.


i had the same problem and i guess found solution.

if you use two google accounts (gmail) you should have two bi online accounts.



@AlexTandem - can you explain a bit in detail about this approach? Right now we have 3 google service accounts for 3 environments/workspace (dev,qa and prod) and I have one power bi developer pro account. we connect to big query data using the google service accounts.
I am also facing scheduled refresh failure in all environments randomly with "Expression.Error: The key did not match any rows in the table". 
Every time there is failure I re enter the credentials in service and the scheduled refresh works (this link helped me) fine after that for that day. But the next day the same issue happens and I have to re enter the credentials again.

Regular Visitor

Here's what worked for me:


- Have your replacement source file (e.g. excel file) ready to go.  Make sure the file name and sheet names are the same.  

- Then in PBI, in the Fields panel, right-click on the troublesome field.  Delete it.  The graph it populates will be replaced by a placehoulder saying "Something's wrong with one or more fields. Fix This".  DON'T DO ANYTHING to the graph at this point.

- Instead, imediately click on Get Data.  Select the new file and in a moment or two your graph should re-populate with the new data, and even retain the original formatting (e.g. colors, etc.).  Hope this works for you.  

Frequent Visitor

I ran into this error and learned that the navigation step in the query was referring to a SQL table and that the table name was case significant.   I had changed the database table from "sales" to "Sales" and ran into the thread title error both from PowerBI on my desktop and PowerBI web service.   I capitalized the table name in the navigation step and everything went back to working as it previously was.  Different cause, but wanted to share my experience and fix.  

Frequent Visitor

Again, a different cause  - similar to Erik's post -the user's permissions were accidentally altered on a SQL Server database so that the table was no longer available (ie no SELECT was granted) and the error will occur. Can reproduce error (SQL 2014 and 2016). So check your table permissions just in case something has changed.

Frequent Visitor

I ran into this error and learned that the navigation step was referring to a SQL table and that the table name was case significant.   I had changed the database table from "sales" to "Sales" and ran into the thread title error both from PowerBI on my desktop and PowerBI web service.   I capitalized the table name in the navigation step and everything went back to working as it previously was.

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors