Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Regular Visitor

Dynamics 365 OData error with Power BI desktop

Hi, I am trying to connect Power BI desktop to Dynamics 365 Online. 


After putting in the correct credentials, it starts to load the metadata then fails with this message:

"OData: The feed's metadata document appears to be invalid"


I am using the OData endpoint URL that I copied from the Instance Web API section in D365 Settings eg:

This is a clean install of Dynamics 365 so there is no customisation of the schema.


I can return the metadata in a browser and nothing obvious stands out.


I have successfully connected to a version 8 instance of Dynamics 365 so I know that I have the right steps.


Is there a known issue with Power BI desktop (latest version) and the July 2017 release of Dynamics 365?




Brent McA




Excellent, that got it working.  Thanks.

View solution in original post

Helper I
Helper I


1. I'm new to Power BI

2. I'm connecting to a company that hasn't had CRM online connected to PowerBI before.


Several clients are getting the invalid metadata


For the company I am currently trying I have tried the above solutions and the closest I've come is it connecting but I have no tables showing to connect to. Is something wrong?


if i can see the metadata does that mean it's externalized properly? also say I'm connecting to appsource and it's using the office 365 account for the connection what authentication method should I be using?


very grateful for any help.

Not applicable


Get data: Other > Web

Basic: Add in URL table >

List, To Table, Ok, Column 1 Double Arrow

Sort from Natural Order to Name

Uncheck "User original column name as prefix"


Please confirm that works?

Not applicable

MS support engineer said if you're CRM instance is above, it will now include the fix and Power shouldn't have the issue anymore. 

I am still getting the error


Details: "OData: The given URL neither points to an OData service or a feed: 'https://***'."

Not applicable

There seems to be intermittent service disruption.  D365 was down on Friday.  Today it's fine, but previous the refresh of it on Power BI service wasn't working an hour ago.  The .pbix refreshed fine.  

Not applicable

Correction, manual refresh of the dataset works, but schedule refresh is producing an error. 

Several customers had their appsource start working last week. Definitely a backend problem. 

Not applicable

9.0 and 8.2 within your URL source with both work now too also began enforcing 10+ calculated field query limits in powerbi (some other apps have had this limitation for a while now).

We kept having intermittent issues with powerbi the last few months so we made the move to azure sql data export service. Not too hard to do (Have to change your reports a bit or a lot depending on the report/datasets). Azure sql refreshes incredibly faster and offloads the resources from dynamics if you have a lot of powerbi reports/queries like we did. 

I am new to D356 (Online) and PowerBI. I am tring to bring in an entity into PowerBI desktop and get this error. Yes, I have more than 10 calculated fields. I don't need all the fields in the PowerBI query but I can't load the entity to reduce the columns. What do I need to to begin to shape the query on this entity?

Not applicable

You could try adding a select statement to the URL to handpick the fields you want - For more information search for $select here 

I have updated Dynamics CRM to Version 1710 ( and using V9.0 Odata end point.

I am unable to use my existing tables in the connections to fetch data, it gives error 

"Column name not foung in table"


Also while estabishing new connections getting metadata error and error related to more than 10 custom columns in the entity. I have tried using the old endpoint v8.2 but still getting same errors.

Not applicable

My organisation updated to V9.0 (  over the weekend, in order to get my reports working again I tried simply editing the "v8.2" to 9.0 in the URL.


This didn't work despite the URL being as detailed from the Developer Resources page:

To confirm the correct source required, I chose to create a new query using the Dynamics 365 Connector.

After choosing a random table, I checked the query in advanced editor and found the code had added two extra statements after the url, in addition to updating to "v9.0":


I changed my existing queries to this and now everything is functioning correctly.

I would suggest creating your own new query to check the correct information is being generated rather than assuming what works for me will work for you.


Hope this is helpful to someone.

I get the remote name could not be resolved. Weird. I could connect before.

Compare the URL you are using to what you find in CRM under Settings -> Customizations -> Developer Resources


Mine looks something like this:

New Member

Even I was facing the same issue. It's a known issue in Power BI and has been addresed in june 2018 release 


I am able to connect to D365 (9.0) after this release upgrade


I am using June 2018 release of Power BI Desktop but still get the same error message - Details: "OData: The feed's metadata document appears to be invalid."


This seems to happen with only certain version of Micrsoft Dynamics365

@datachamp wrote:

I am using June 2018 release of Power BI Desktop but still get the same error message - Details: "OData: The feed's metadata document appears to be invalid."


This seems to happen with only certain version of Micrsoft Dynamics365


Sorry to tell you but you'll have to contact MS support and they have to do something in backend to fix this. It's unrelated to version since my version stayed the same before/after their fix. Maybe related to what datacenter it is housed in? Who knows, but if it helps you can give them our ticket# 118062518454992. Microsoft said if we had the issue again it would help to reference the ticket# so they would know what fixed it..


Not applicable

On the Power BI Desktop side:
old = OData.Feed("")
new = OData.Feed("", null, [Implementation="2.0"])

add this in

, null, [Implementation="2.0"]

seems to work, but cannot publish it to the BI workspace as I still get the same metadata error message

New Member


I'm using the Free version for Desktop (in italina Language).

The one from JUNE 2018 (the updated one just downloaded)

My Dynamics 365 Online is this: https://***** but it is not connecting (I'm logging as Dynamics 365 Admin - Not Office 365 Admin). Into the PowerBI Desktop Free Application, appears this error (in Italian because the PowerBI downloaded is in italian): Dettagli: "OData: Il documento di metadati del feed non è valido."

Can you help me?

Thank you.

Helpful resources

Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City


Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors