Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
thimremy
Frequent Visitor

Problem to import the dot from a column

Hello,

 

One of the column I imported from my data source (CSV) is in Euro and has the following format when I open it via Excel:

 

FINAL_QUOTE
46.88
144.69
63.54
20.63
8.9
32.24
8.9
8.9

 

When I open the Query Editor, I find my column without any dot:

 

FINAL_QUOTE
4688
14469
6354
2063
89
3224
89
89

 

Do you have a solution to avoid that dots disappear? Or to re-add a dot in Power BI (but I'm afraid it's not possible as there isn't always two decimals so we can't decide to add a dot before the last 2 figures)?

 

Thanks a lot for your help,

 

thimremy

1 ACCEPTED SOLUTION
cs_skit
Resolver IV
Resolver IV

You probably have non-english regional settings right?

It happens for example when you have german CSV where delimiter is Semicolon but decimal seperator whould be comma but in your file its dot. Then he does not auto detect that.

 

Solution is when using GET DATA Text/Csv in the following window on Data Type Detection select "Do not detect data types"

then it is imported as text and you can change it in Query Editor.

View solution in original post

3 REPLIES 3
v-ljerr-msft
Microsoft Employee
Microsoft Employee

Hi @thimremy,

 

Have you tried the solution provided by @cs_skit above? Does it work in your scenario? If it works, could you accept it as solution to close this thread?

 

If you still have any question on this issue, feel free to post here. Smiley Happy

 

Regards

cs_skit
Resolver IV
Resolver IV

You probably have non-english regional settings right?

It happens for example when you have german CSV where delimiter is Semicolon but decimal seperator whould be comma but in your file its dot. Then he does not auto detect that.

 

Solution is when using GET DATA Text/Csv in the following window on Data Type Detection select "Do not detect data types"

then it is imported as text and you can change it in Query Editor.

Hello cs_kit,

 

Thanks for the piece of advise, it worked!

 

Have a nice day,

 

thimremy

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.