Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Mamabox
Regular Visitor

PowerBi Report wont work after publishing in app.powerbi.com

Hello,

my company is currently facing a strange interaction.

I got some PowerBi Reports from Finance and they wont them published in Teams.
We already used MySQL Reports and had no issues whats so ever.

My Implementations looks as following:
On Prem Connector on AAD and DC Server.
AAD User is logged in and an lokal Service User is in use.

The Report got published in a spezific workgroup.
Gateway is assigned and online(Is working with other Reports already)
Datasource is a Analysis Service on a SQL Server.

Mamabox_1-1663771162486.png

The provided local User is sql server admin and a connect via sql server management is possible for example.
The Datasource is online aswell.

But as soon as i open the report i got the following error message:

Mamabox_2-1663771259956.png

 

Where could my mistake be. Got an local connection. Gateway is working with other reports but this one wont work.

Best regard,
Michael Seidel

1 ACCEPTED SOLUTION
v-luwang-msft
Community Support
Community Support

Hi @Mamabox ,

When you have "Live connection" set up people viewing the dashsboard must have access to the data source.  Please check if the service account(s) you're using for SSAS/EGW has "Read" permission on the AD user in acrtive directory. I had an issue this week where one user had "Read" for "Authenticated Users" checked, and the other had not (and that user's connection failed).

 

refer:

https://community.powerbi.com/t5/Power-Query/Power-BI-This-report-could-not-access-its-data-source-p... 

 

 

Best Regards

Lucien

View solution in original post

1 REPLY 1
v-luwang-msft
Community Support
Community Support

Hi @Mamabox ,

When you have "Live connection" set up people viewing the dashsboard must have access to the data source.  Please check if the service account(s) you're using for SSAS/EGW has "Read" permission on the AD user in acrtive directory. I had an issue this week where one user had "Read" for "Authenticated Users" checked, and the other had not (and that user's connection failed).

 

refer:

https://community.powerbi.com/t5/Power-Query/Power-BI-This-report-could-not-access-its-data-source-p... 

 

 

Best Regards

Lucien

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors