Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
AiyooDa
Advocate II
Advocate II

PowerBI Desktop Query Refresh Popup Not showing up

Since today morning, whenever i right click a table in the data pane and click on "Refresh Data", the window that usually pops up (with creating connections, number of rows loaded and errors etc) is not coming up. After a while it looks like the table is refreshed, but only when i hover the mouse over it. 

 

Any help on how to get the popup back pls?

1 ACCEPTED SOLUTION
Idrissshatila
Super User
Super User

Hello All,

 

The issue has been sloved in Version 2.130.930.0.

Download Microsoft Power BI Desktop from Official Microsoft Download Center



Did I answer your question? Mark my post as a solution! Appreciate your Kudos
Follow me on LinkedIn linkedIn
Vote for my Community Mobile App Idea

Proud to be a Super User!




View solution in original post

53 REPLIES 53
Ronald_Antony
New Member

I am also getting the same issue, Due to which i am unable to refresh the data, I have tried forceclose the window and restarted the system to refresh the data.

v-yaningy-msft
Community Support
Community Support

Hi, @AiyooDa 

Thanks for @PanaFatouros @Syndicate_Admin @royce4 @AniBanani2020 reply in this topic. We are verifying this issue and you can roll back to the May version until the issue is resolved.

Download link for previous versions:
Previous monthly updates to Power BI Desktop and the Power BI service - Power BI | Microsoft Learn

Best Regards,
Yang
Community Support Team

PanaFatouros
Regular Visitor

Replying here to add responses to this thread. I am having the same issue.

 

Incredibly frustrating! I have wished for a similar feature to be able to refresh and still work on the report visuals without having to wait. Though it is difficult with this as it's hard to know when the report finishes loading. Maybe a progress bar needs to be added to the diagram page atleast?

 

---- Update ----

Reverting to May verison fixed the issue.

Syndicate_Admin
Administrator
Administrator

Hello, I report the same problem... and it doesn't let me edit the queries to see the errors either (He keeps thinking and doesn't open the window) and I don't know how to get to the errors from the Model. I can't go back to the previous version, because I don't have Admin permissions on my computer. Help! (But if you're updating data, I just don't see the status)

royce4
Regular Visitor

Same issue. Been doing this since Tuesday. 

Makes it difficult to discern when a refresh is complete so I can save the report. So this is basically creating a lot of down time for fresh data for our reports. We cannot tell when the refresh actually completes to save and then when we try to save it hangs. 

I will try to install the May version.

AniBanani2020
Frequent Visitor

Adding for critical mass here. Experienced the same issue. Luckily i was able to roll back to an older version

Facing same issue since last 4~5 days, waiting to get it resolved. For the time being is any other ways to get it fixed.

What a relief to read this, I thought I had messed something up, I even unistalled, wiped out the cache, reinstalled and started again. Only to still have it. Well I guess it is now up to Microsoft to fix it.

Syndicate_Admin
Administrator
Administrator

Hello!, the same thing happens to me here, it is difficult to know if the information is really being updated, although I have checked in tables that have the upload date field that it is updated.

Hopefully there's more information on this, or if there's a way to set the window to appear.

sarilaurencohen
New Member

Thank you for asking this question! I am experiencing the same issue and it is definitely frustrating. While it is nice to have the option to work while refreshing I'd sacrifice that to know where I stand with regard to refresh progress/status/success.

alex20274
Frequent Visitor

Might seem odd but since my reply to this thread earlier, I can now refresh at regular intervals via the icon on the ribbon whereas before I couldn’t, however I still cannot refresh by right clicking on any of my data tables. Feels like the issue could be intermittent.

 

By the way this is on several of my models

Bertu
New Member

Did you guys find anything on this problem?

 

It is really frustrating

Hi @Bertu -As suggested by @lbendlin reinstall 2.129.1229.0 and wait for Microsoft to issue a fix or 

you can rollback to May 2024 relase until the issue fixed . 

Check the below link to install the previous power bi desktop may 2024 release.

 

Previous monthly updates to Power BI Desktop and the Power BI service - Power BI | Microsoft Learn

 

 

you can find the exe file. download it. Hope it helps

rajendraongole1_0-1718262033906.png

 

 

Did I answer your question? Mark my post as a solution! This will help others on the forum!
Appreciate your Kudos!!

I'm not happy it's happening to you - but I also am ... I have been pulling my hair out trying to figure out why this is happening and my Google searches + Chat GPT queries have produced ZERO examples of this happening before -- but as of 6 hours ago, this post exists.

 

Seems it's related to the "update"... Good lord I hope they fix it soon - this is VERY frustrating.

alex20274
Frequent Visitor

I noticed this in my models yesterday, however I have found when opening one of my desktop models for the first time it will refresh only using the refresh option on the home ribbon, but not right clicking on a data table. However, refresh pop-up doesnt appear a second time. I have also found when trying to refresh say a second time and no pop-ups show, my laptop is whirring away suggesting something is happening in the background and as mentioned above if you hover over one of the tables it shows it having refreshed. However, I’m reluctant to believe this as some large tables shows a refresh too quickly.


On top of this I have also noticed since yesterday my models will sometimes freeze and I have to manually force them to close.


Again, my only workaround is as mentioned above, refreshing when first opening via the home ribbon, then closing and opening again, this is not practical when I’m working on large models with big data sets.

VicLin2024
New Member

Same issue clicked the refresh, and nothing popped up. The data does not event get refreshed. 

MPRGray
Advocate I
Advocate I

same issue here. Started happening to me yesterday afternoon after my PBI Auto-updated to the June release. 
Aside from no refresh popup, there have been a couple of times where trying to only refresh one table has caused all of my visuals to go blank.

jmh2020
Frequent Visitor

Same case experienced earlier today 8.00 AM Central Euro Time.

I am on Version: 2.130.754.0 64-bit (June 2024)


The refresh is actually performed, but there is no visual context menu to inform on its progress.


The refreshed data somehow appears when you hover your mouse on the table.

 

jmh2020_0-1718186048879.png

 

 

Anyway to reverse it? Show the popup?

The "normal" refresh window seems to be back on
Version: 2.130.930.0 64-bit (June 2024)

I am not sure if mine is the same issues as the others on here, but for one Power BI file (desktop) when I click refresh (on the specific table I want to refresh), all that pops up is the SQL in the query. Very odd.

My other reports are working fine.

I have tried logging out and back in again, and have alos tried editing the query and refreshing that way - in the latter method, the query refreshes, but then all other functionality goes - right down to not being able to close Power BI other than via Task Manager

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

Top Solution Authors