Showing results for 
Search instead for 
Did you mean: 

Fabric is Generally Available. Browse Fabric Presentations. Work towards your Fabric certification with the Cloud Skills Challenge.

Helper I
Helper I

'Oracle.Databases.Client' could not be instantiated

In PowerBI, I can "Get Data", and the columns appear in the "Fields" section. However, when I select a field, this error appears:


"Could not load the data for this visual"

Error:The managed provider 'Oracle.DataAccess.Client' could not be instantiated. Unable to find the requested .Net Framework Data Provider. It may not be installed.


(I suspect it could be a 32 vs 64 bit thing, but not sure how I should resolve it)

Frequent Visitor

Folks - I ran into this issue and have been troubleshooting all afternoon.


My initial config...

  • PBI desktop 64bit (june 2017 release) installed
  • existing 11g 32bit Oracle client
  • new 12c Oracle Data Access client installed
  • path updated to place new 12c Oracle home first

Even after downloading and installing the ODAC 12C and updating my path, my PBI desktop continued to throw errors when trying to build a viz with direct connection to Oracle Database.


I downloaded the 32bit version of PBI Desktop and it works as expected... no issue.


My question is - can we have 32bit and 64bit Oracle clients side-by-side whereby we are able to use PBI Desktop 64bit and Visual Studio (SSDT) to develop SSRS reports?  The PBI desktop wants the 64bit ODAC and Visual Studio wants the 32bit client!!


Help please...


Thanks - Nick 

We have the 32-bits and the 64- bits oracle driver installed on our machines. We use 64 bits Power BI Desktop (may release). We use Excel 32 bit. And both tools can connect to an Oracle database.


In the PATH variable we have first the 32-bits settings and after that the 64-bits settings.

Thanks @Knud - I actually worked through the issue last night.


In my haste (and ignorance)  I didn't install the full Oracle client 64 bit - only the ODAC components.

So, after deinstalling all Oracle clients I did the following which resolved the issues:


1. Install Oracle 12c 64bit Client into a specific directory ie. "c:\oracle64" 

Oracle Database Client ( for Microsoft Windows (x64)


2. Install Oracle 12c Oracle Data Access Components 64 bit into the same directory (c:\oracle64).

64-bit ODAC 12.2c Release 1 ( for Windows x64


3.  Install Oracle 12c 32bit Client into another specific directory ie. "c:\oracle32"

Oracle Database Client ( for Microsoft Windows (32-bit)


The results are good for my situation.  I am now able to connect to an Oracle database from PowerBI desktop 64bit without issue.  Additionally I can build visualizations over the connection.  Finally my Visual Studio projects which use oracle connections also function as expected - using the 32bit Oracle client.




@dennisr you need to install the Oracle driver:





The ODC library has been deprecated.

I should have mentioned... I had already done that.

I installed

I already had instant client 11 installed prior, both 32 & 64 bit, and my PATH had the 64 bit folder before the 32 bit folders.

After I installed ODAC, into a completely new folder (c:\Oracle), I put c:\Oracle and c:\Oracle\bin into the front of my PATH and removed the prior folders from the path.


I'm striking the same error.  It seems like an obvious bug to me that you can navigate and preview the data using whatever drivers, but then you cant generate a visual.


@dennisr - did those steps your described in your last post solve your problem?



I just didn't have time to continue playing with it, as I was just evaluating PowerBI.  So, I just did "Import" rather than direct.  I stil suspect it's related to some 32 vs 64 bit issue.

Thanks Dennis.  I think my machine has both Oracle 32 and 64 bit drivers, but they were the older 11GR2 client.


Following that tip from @pquian I downloaded the "64-bit ODAC 12c Release 4 ( for Windows x64" (, and installed it using the default settings.  It now seems to be working.


It still seems like a clear bug to me that you can connect and model using some Oracle Drivers, but can't visualise until other drivers are installed.  Surely all PBI tasks should use the same drivers? There are lots of other risks e.g. inconsistent drivers, performance, TNSNAMES configurations.



OK it worked ... for a while, all the way through to PBI Web querying via the Enterprise Gateway (after I installed ODAC121024_x64 on that machine). 


But today it is working in PBI Desktop, but after re-publishing to PBI Web every visual returns an error:

Couldn't load the data for this visual
We reached the enterprise gateway, but the gateway can't access the on-premises data source.
Please try again later or contact support and provide the following details to help resolve your issue faster.
Error CodeDM_GWPipeline_Gateway_DataSourceAccessError



Digging into the PBI Gateway log I'm seeing lots of errors "Unable to find the requested .Net Framework Data Provider.  It may not be installed.".


From the Settings / Gateways page the connection tests OK.  I tried restarted the PBI Gateway service.



I instaled the   I verified that my PATH was updated with the leading 



I still get the same error with the visual.

I "frowned" the error this time, and got a reply back...


...This is an issue several customers have hit. We've fixed it in the upcoming release....

[I asked for ETA, and they said ...]

...our monthly release will be available on Thursday, May 26th. You will be able to download it at:



Frequent Visitor

I have exactly the same problem.


The Power BI Desktop version I use is 2.36.4434.381 64-bit (juni 2016).

So the problem is still not solved?

Problem exists at this moment at our company when files are based on direct query. Still looking for the solution. Any help????

Fout Power BI.png


Not applicable

Installing the ODAC client resolved our issue.

Not applicable

@Hyperchef1969 , i also have same problem for direct query, is it solved for you.

If yes, can you please let me know 




Check if server password is not expired. That was the problem in our case.

Regular Visitor

Hi All,


I still get this error. We installed ODAC 12c release and installed Oracle Data Provider for .Net And from Power BI Edit Query, I preview data, but when I create Visual report, I got error 

Error Message:
The managed provider 'Oracle.DataAccess.Client' could not be instantiated. Unable to find the requested .Net Framework Data Provider. It may not be installed.


Here is detail. Did I miss any setup? Appreciate any help. thx




Actually it's working fine for me on multiple machines.  The key seems to be installing and configuring that 64-bit ODAC client driver on all machines.



I faced same issue now. I have ODAC 12c installed, and my Power BI desktop version is Version: 2.42.4611.901 64-bit (January, 2017). In Power BI desktop. I can view data in Edit Query windows, but when I added to visual, I got error The managed provider 'Oracle.DataAccess.Client' could not be instantiated. Unable to find the requested .Net Framework Data Provider. It may not be installed. I saw you solve the issue by configure ODAC, here is what I have ODAC component installed. Not sure missed anything. 




Appreciate any help.




Is your Oracle install 64-bit?

Helpful resources

PBI November 2023 Update Carousel

Power BI Monthly Update - November 2023

Check out the November 2023 Power BI update to learn about new features.

Community News

Fabric Community News unified experience

Read the latest Fabric Community announcements, including updates on Power BI, Synapse, Data Factory and Data Activator.

Dashboard in a day with date

Exclusive opportunity for Women!

Join us for a free, hands-on Microsoft workshop led by women trainers for women where you will learn how to build a Dashboard in a Day!

Power BI Fabric Summit Carousel

The largest Power BI and Fabric virtual conference

130+ sessions, 130+ speakers, Product managers, MVPs, and experts. All about Power BI and Fabric. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors