Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Anonymous
Not applicable

Optimize memory

Hi!

Please help me how to optimize, reduce the memory consumption in Power BI Desktop. I've got the message that I runned out of memory during refresh. I have a complex database with lot's of calculated columns and about 10 tables. I tried to delete the columns which are needn't but it's not enough. I'm running the 64 bit version with 8 GB. 

Thank you in advance for your help!

Máté

1 ACCEPTED SOLUTION

@Anonymous,

 

Did you have large data in your data source? Please try to uncheck "Allow data preview to download in nthe backgroup" and "Enable parallel loading of tables" and check if this issue persists or not.

Capture.PNG

 

Regards,

Charlie Liao

View solution in original post

6 REPLIES 6
Brunner_BI
Super User
Super User

You should try to remove unused columns (measures are more like optional) from your data model using external tools like Measure Killer

bsas
Post Patron
Post Patron

Hi,

 

Recently I experienced the same situation. Calculated columns especially when you have big amout of values in them need a lot of memory to do calculations. To avoid such situation please use measures insted of calculated comumns. They run dynamically and save a lot of memory. 

Anonymous
Not applicable

Thanks for your reply!
I tried to do more measures but it's still the same message with not enogh memory.. Have you some other thoughts how can I reduce it?
Many thanks!

One more thing which I used. You can write direct SQL Query and indicate needed fields and period when you're getting data from your database. This will get less data from DB.

 

Don't know if in your case you can filter data before uploading from DB.

 

Or you can use filters e.g. Page filters, report level filters to show less data in visual, but I'm not sure if it saves memory, maybe just run report faster.

Anonymous
Not applicable

Yes, but now I can't change the source from import to direct query and it would be really difficult to do an other report:/ 
And now I have only a few claculated columns, but it's still too many datas to refresh..

@Anonymous,

 

Did you have large data in your data source? Please try to uncheck "Allow data preview to download in nthe backgroup" and "Enable parallel loading of tables" and check if this issue persists or not.

Capture.PNG

 

Regards,

Charlie Liao

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors