Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
pheller
Regular Visitor

How-to turn off summarization on all table columns and no implicit measures on the visualizations?

How-to configure turning off summarization on all table columns of the model?  In addition,configure turning off implicit measures on the visualizations as the default?

 

This would allow by exception setting the summarization on the column or changing a the column in the visualization to an implicit measure.   

 

Shouldn't all measures be created explicitly? 

 

  1. Step 1 all of the columns are set manually to Don't Summarize.  Using EmployeeID as an example
  2. Step 2 Dragging EmployeeID to the table immediately changes it to an implicit count when I just wanted to show the EmployeeID

 

pb.jpg

5 REPLIES 5
v-lionel-msft
Community Support
Community Support

Hi @pheller ,

 

For numeric fields, PBI Desktop will automatically aggregate, you just cancel it manually.

v-lionel-msft_0-1599099760608.png

Why the Default Summarization Property in Power BI is So Important 

 

Best regards,
Lionel Chen

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

amitchandak
Super User
Super User

@pheller , Under the model tab, You can click on columns under advance option you have Summarize by. You can select multiple column using ctrl or shift and can change them together

Advance Property in Model.png

SteveCampbell
Memorable Member
Memorable Member

First, make sure you have the latest version of Tabular Editor downloaded.

 

Next, restart Power BI and open your file.

Click External Tools and select Tabular Editor.

 

Open Advanced Scripting and paste the following code:

foreach (var c in Model.AllColumns)
{c.SummarizeBy = AggregateFunction.None ;}

 

Save the tabular editor file back the the database (ctrl-S)

Return to Power BI and Refresh your model.



Did I answer your question? Mark my post as a solution! Proud to be a Super User!


Connect with me!
Stay up to date on  
Read my blogs on  



Thanks this worked for me 🙂

This is excellent in terms of achieving the default value of "do not summarize" using the Tabular Editor.

You need a way to turn off summary in the visualization to avoid implicit measures as default. They should be by exception (turning them on manually) and eventually replacing them with explicit measures.

Thank you for your suggestion. I used Google's translator to respond in Spanish.

English:

This is excellent as far as accomplishing the default value of "do not summarize" using the Tabular Editor.

Need a way to turn off summarize in the visualization to avoid implicit measures as the default. They should be by exception (manually turning them on) and eventually replacing them with explicit measures.

Thank your suggestion. I used google translate to respond in Spanish.

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Top Solution Authors