Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
ozmike
Resolver I
Resolver I

Formula Firewall ..?

 

Hi have a query an get this error ..

 

 

 

Formula.Firewall: Query 'CallListquery' (step 'Source') references other queries or steps, so it may not directly access a data source. Please rebuild this data combination.

let
xx =   KEYListfunction(),
sel = "select * from ""XXX.xx::XXX""  where ""column"" IN  ("  & xx & ")  ",
Source = SapHana.Database("XXX:12345", [Query=sel])
in
Source

 

How to rebuild?

 

Basically KEYListfunction(), returns a comma separated list

 

'123', '345'

to generate a

 

select * from xxx where col in ( '123', '345' )

 

This works ..when the query doesn't ref the list function..

let
xx =   KEYListfunction(),
sel2 = "select  * from ""XXXX""  where ""col"" IN  ('123') ",
Source = SapHana.Database("server", [Query=sel2])
in
Source
1 ACCEPTED SOLUTION
MarcelBeug
Community Champion
Community Champion

The cause of the error message is that you use data from another table (in your KEYListFunction) to access data in your Saphana database. Such a combination may violate privacy level settings.

 

Probably the only way to solve this issue is to adjust your privacy level settings:

go to File - Options and Settings - Options - Privacy (almost at the bottom) and check

"Ignore the Privacy Levels and potentially improve performance".

On that screen you can also find a link to more information on privacy levels, which brings you here.

 

Specializing in Power Query Formula Language (M)

View solution in original post

4 REPLIES 4
GilbertQ
Super User
Super User

Hi @ozmike

 

Possibly try this

 

let
xx =   KEYListfunction(),
sel = "select * from ""XXX.xx::XXX""  where ""column"" IN  ("  & #"xx" & ")  ",
Source = SapHana.Database("XXX:12345", [Query=sel])
in
Source

If the above works, when you define a parameter or as in your example the (xx) when then using it within the Query Editor it has to have the HASH DOUBLE QUOTE PARAMETER NAME DOUBLE QUOTE - #"PARAMETER" 





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

MarcelBeug
Community Champion
Community Champion

The cause of the error message is that you use data from another table (in your KEYListFunction) to access data in your Saphana database. Such a combination may violate privacy level settings.

 

Probably the only way to solve this issue is to adjust your privacy level settings:

go to File - Options and Settings - Options - Privacy (almost at the bottom) and check

"Ignore the Privacy Levels and potentially improve performance".

On that screen you can also find a link to more information on privacy levels, which brings you here.

 

Specializing in Power Query Formula Language (M)

Thanks this works!

 

BTW i didn't need the hash my original solution code worked just with teh open policy settings.. 

 

i'll have to investigate why there are different policy setting on an XLs vs HANA table.

Hi @ozmike,

 

Glad it is now working and in theory it should work on an XLSX file also.

 

I do know of some issues with XLS files that I have encountered in the past (If that is what you meant with your explanation.)





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

Top Solution Authors