Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Regular Visitor

Error 500 Internal Server Error when publishing a PBIX file



With the August 24 release of Power BI I am getting an error where I am unable to publish my PBIX files to


The error message that I get is



I get this error with all of my pre-existing Power BI reports. (These are all reports that connect to a local excel spreadsheet.)


The strange thing is that if I take a copy of any of these files, paste as a new name (e.g. Insurance2.pbix), and then publish to, that first-time publish will work. But if I were to attempt a republish of this new file, it will come up with the same error message.


Prior to the August release, I was intermittently getting the Error 400 issue outlined by another user. The only solution I had was to delete the report and dataset, then republish, but that was a pain because each report would have a new URL and I would have to repin the visuals. It makes it difficult to get wider scale adoption of powerbi in our organisation.


Is anyone else getting this Error 500?



Advocate I
Advocate I

Year 2023, same issue... No fix yet? 😞

New Member

I have the same issue and it seems that after 5 years, no one came with a solution to this problem, how is this possible?

Microsoft Employee
Microsoft Employee



I'm having the same issue trying to republish a report based on an existing PBI dataset.


I've already tried a lot of things like reinstalling PBI and even downloading the PBIX file from the service and publishing it again. The result is the same... It's really painful


Does someone can help here?


Thank you very much in advance.



Frequent Visitor

I also get the same error.

Not applicable



I'm having the same error when attempting to publish a Power Bi file to a workspace on Power Bi Service. I already tried to import it to my workspace on Power BI Service and it doesn't do it!


I already tried to publish the same file with a diferent name but it doesn't work either.


I'm using the following version: 2.65.5313.841 64-bit (December 2018).


Can anyone help me please?


Thanks in advance.


Best regards,





Helper III
Helper III

I am also getting same error while publishing report using Azure HDInsight Spark connector to connect to Hive tables.

I already posted a question on community : Link


Even tried to get data from Spark connector in Power BI service,  i am getting error "We are unable to establish connection, please check connection information."


Please let me know if you are able to resolve the issue or you got any solutions/workarounds.


Microsoft Employee
Microsoft Employee

Hi samngai,


I tested with Power BI desktop August Update version, but didn’t encounter the 500 error when publishing old PBIX file to Power BI service.

A republish would remind me if I would like to replace the dataset.

To investigate further, please follow the steps below:

  1. Check the temp folder, C:\Users\User name\AppData\Local\Power BI, find the latest file after reproduce the issue and open it with notepad;
  2. Enable Tracing under Power BI Desktop File->Options and settings->Options->GLOBAL->Diagnostics, select Enable Tracing;
  3. Generate a Fiddler trace. (Fiddler Web Debugger Tool)

If available, upload them into OneDrive and post the shared link here. We will help to take a look.

In addition, try to take a reinstall or a repair of the Power BI desktop, see if this would make any difference.


Thanks Michael_Shao,


I think Power BI used to ask me if I wanted to replace the dataset before loading. But I don't get this prompt anymore Error 500 comes up.


The Fiddler Trace shows the following.




And the Power BI Trace shows the following.


{"dt":"e","ct":1472623943,"u":"ee15a6e3-f2f0-4151-8ab1-cdf70c42d9ff","su":"a76a725a-d92a-41c2-ab66-e539c239a37f","n":"PBI.Win.UploadReportToPowerBIService","attrs":{"backendUrl":"","activityId":"79bc70ab-beb9-4593-a5cf-eea4964dd4a2","requestId":"7c0485f6-... - 100ms","client":"WinDesktop","build":"2.38.4491.282 (PBIDesktop)","uiCulture":"en-US","clientCulture":"en-AU","isInternal":"False"}}
{"dt":"e","ct":1472623947,"u":"1e1ed5c0-f74f-4578-b7f1-78da446620ee","su":"a76a725a-d92a-41c2-ab66-e539c239a37f","n":"PBI.PQ.PublishingFailedInternal","attrs":{"backendUrl":"","activityId":"79bc70ab-beb9-4593-a5cf-eea4964dd4a2","requestId":"7c0485f6-... (PBIDesktop)","uiCulture":"en-US","clientCulture":"en-AU","isInternal":"False"}}


Sorry that I can't load this in OneDrive. Our organisation actually doesn't have OneDrive set up.


It sounds like Power BI isn't asking me whether I want to replace the dataset with the existing, anymore. Is there a way that I can re-enable this in Power BI?

I will also reinstall/repair Power BI to see if that helps.


Update: I repaired Power BI. No difference in outcome. Power BI doesn't ask if I want to replace the dataset, instead jumping straight to Error 500.

Hi samngai,

Thanks for the update.

The error code in the fiddler tool showed that"ExcelworkbookAlreadyImported", there is nothing else helpful that I could find out from the trace information posted.

The trace from my side didn't show any errors when re-publish the PBIX file.

I will report this and if any further update, will post back.



@samngai, like Michael I can't reproduce your issue either. Would you mind uninstalling Power BI Desktop completely to install it again? You can get the PBI Desktop from the link: 

Hi Michael and Vicky. A complete uninstall, reboot, and reinstall did not fix the issue. But it does seem like I am the only one impacted.

Impactful Individual
Impactful Individual

@samngai, your issue looks strange to me. I will try to involve other senior engineers. 

@samngai, I need further information from your side:

1). Are there any proxy servers set in the environment?

2). Are you able to import the PBIX file into the service from the Get Data portion within the PBI service?

Hi Vicky,


1) Yes there are proxy servers in the environment. I'm guessing this is what's contributing to the issue. Though the issue only appeared in recent times so I'm wondering whether there's a change in how Power BI Desktop connects to the cloud, or whether it's a change in our proxy settings.


2) Importing the PBIX into the service via PBI Service Get Data works in refreshing the report when the underlying Excel spreadsheet's structure does not change.
But if we update the underlying Excel (e.g. add additional columns and link visualisations to the new columns), then upload via PBI Service Get Data, the charts will not work. In the example below, "Agree", "Partially Agree", "Partially Disagree", and "Disagree" are all additional columns that we added to the Excel spreadsheet prior to an upload.





I am having this issue also with a newly created pbix file, exact same error message, except filename is obviously different. I have tried refreshing and saving data before attempting to publish, I get no error messages when I do this to make me think there is a problem with the data but when I try to publish I get an error 500. Is there an internal log file I can access that might give more detail as to the cause of the error, its kind of annoying and a bit of a show stopper





Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.