Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Not applicable

Do not show the first row values when expanded using matrix



How do i not show the first column values of the minimized table of the matrix?



[+] January |  Want blank  |    Want Blank |  Want Blank |


It was fine when its expanded, first row is blank.


[-] January |  Heres Blank |    Heres Blank |  Heres Blank |

                  |           1         |    6                  |  Yes             |


Thanks and Regards,


Helper I
Helper I

I have the same issues nearly 4 years later. Cannot believe they don't have like a "Show Values when collpsed" toggle. It can be very confusing for the user if you are utilizing descriptive data instead of numeric data.


Hope something pops up soon!

I have tried to find a fix for this issue temporarily , manually expand the + icon for the matrix all rows, go to the setting of the matrix visual , under the row headers, disable the +/- icon to get the effect of having values only in the expanded rows and not totalling out when a user presses - symbol. Hope it helps ! 



New Member

Hi there,


I've managed to find a workaround for this. It's not the best but it's a very simple procedure. First of all, you have to know the main colors of your report. 


So you go to the "Cell elements" property of your matrix, enable "Font color" and in the 'fx' button you have to configurate accordingly to your report colors. You set the collapsed value to be the same color as your background (in my example, white) and the expanded to be the one you want for your fonts.


Set the range based on your data (in this case I've put anything between 2 and 40), remembering that for PowerBI this means the total count of the subrows under the main row. The other rule you set to "1" since the count will be allways 1 when you expand the rows (you have to be using two-level matrix to work exactly like above). 


It'll be something like this:





Mr. Barbosa


I have the same problem, did you find any solution for it?

having the same issue here... did you finally figured it out?

Super User
Super User

@Anonymous , Not very clear. But isinscope should able to help you

Not applicable

Hi Amit,

I want it to be like this, hightlighted row is blank when not expanded.



It shows values when it not expanded.


Sorry for my bad explanation. I suspect its showing the 'First Value' alphabetically sorted.


Turn off the row subtotals, it is on by default.

row subtotal.JPG


Paul Zheng _ Community Support Team
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.


Not applicable

Hi Paul,


I have already turned it off, anyway it doest not toggle the first row to appear nor disappear, only the totals below.

Not applicable

Hi any kind souls able to help on this?

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.


Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors