Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Reply
Anonymous
Not applicable

Do not show the first row values when expanded using matrix

Hi, 

 

How do i not show the first column values of the minimized table of the matrix?

 

E.g

[+] January |  Want blank  |    Want Blank |  Want Blank |

 

It was fine when its expanded, first row is blank.

 

[-] January |  Heres Blank |    Heres Blank |  Heres Blank |

                  |           1         |    6                  |  Yes             |

 

Thanks and Regards,

V

10 REPLIES 10
HavenerTed
Frequent Visitor

I have the same issues nearly 4 years later. Cannot believe they don't have like a "Show Values when collpsed" toggle. It can be very confusing for the user if you are utilizing descriptive data instead of numeric data.

 

Hope something pops up soon!

I have tried to find a fix for this issue temporarily , manually expand the + icon for the matrix all rows, go to the setting of the matrix visual , under the row headers, disable the +/- icon to get the effect of having values only in the expanded rows and not totalling out when a user presses - symbol. Hope it helps ! 

kiranbaby88_0-1714694486272.png

 

MrBarbosa
New Member

Hi there,

 

I've managed to find a workaround for this. It's not the best but it's a very simple procedure. First of all, you have to know the main colors of your report. 

 

So you go to the "Cell elements" property of your matrix, enable "Font color" and in the 'fx' button you have to configurate accordingly to your report colors. You set the collapsed value to be the same color as your background (in my example, white) and the expanded to be the one you want for your fonts.

 

Set the range based on your data (in this case I've put anything between 2 and 40), remembering that for PowerBI this means the total count of the subrows under the main row. The other rule you set to "1" since the count will be allways 1 when you expand the rows (you have to be using two-level matrix to work exactly like above). 

 

It'll be something like this:

 

solutionworkaround.png

 

Regards,

Mr. Barbosa

@Anonymous

I have the same problem, did you find any solution for it?

having the same issue here... did you finally figured it out?

amitchandak
Super User
Super User

@Anonymous , Not very clear. But isinscope should able to help you

https://www.kasperonbi.com/use-isinscope-to-get-the-right-hierarchy-level-in-dax/

Anonymous
Not applicable

Hi Amit,

I want it to be like this, hightlighted row is blank when not expanded.

 

1.jpg

It shows values when it not expanded.

2.jpg

Sorry for my bad explanation. I suspect its showing the 'First Value' alphabetically sorted.

@Anonymous 

Turn off the row subtotals, it is on by default.

row subtotal.JPG

 


Paul Zheng _ Community Support Team
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
 

 

Anonymous
Not applicable

Hi Paul,

 

I have already turned it off, anyway it doest not toggle the first row to appear nor disappear, only the totals below.

Anonymous
Not applicable

Hi any kind souls able to help on this?

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.