Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
chris7777au
New Member

Date field is being displayed as date hierarchy [year][quater][month][day] in visual

Ok so i'll preface this by saying Im new to PowerBi datasets so if i've missed something obvious go easy!.

 

I am sourcing data from Dynamics Business Central via API.  A field i'm sourcing is the Order Date for a sales order.

 

If I select the Data tab, I can see the value in the data table as a single date (i.e. "03/05/2022") but in the Fields pane, the Order date is split with a Date Hierarchy, which seperates Year, Quarter, Month and Day.  When I attempt to put the field Order Date into a visualisation table, it automatically inserts 4 seperate Columns (Year,Quater,Month,Day) rather than one column being Order Date.  H

 

The Order Date field is showing as a Date Hierarchy.  How do I insert the Date rather than breaking it out inot the Date Hierarchy?

 

Order Date HierarchyOrder Date Hierarchy

 

Can someone point me either to the right way to fix this or some documentation?  

 

Thanks.

2 ACCEPTED SOLUTIONS
PC2790
Community Champion
Community Champion

As by default, time intellegence is enabled so the dates are automatically viewed as an heirarchy.

If you want to have single column of date in your visualisation, you can change the settings in your visualisation pane to use date as below:

PC2790_0-1652422142526.png

 

And if you want to remove this hierarchal structure all together, 

Go to  File --> Options and Settings --> Options --> Current File -> Data Load and turn  off 'Auto Date/Time' (under Time Intelligence)

But I would suggest to have it and change the view fro your visualisation base don your requirement

View solution in original post

jsaunders_zero9
Responsive Resident
Responsive Resident

In your visual try clicking the arrow drop down and changing it from Date Heirachy to Date.

jsaunders_zero9_0-1652422192988.png

 

View solution in original post

3 REPLIES 3
jsaunders_zero9
Responsive Resident
Responsive Resident

In your visual try clicking the arrow drop down and changing it from Date Heirachy to Date.

jsaunders_zero9_0-1652422192988.png

 

PC2790
Community Champion
Community Champion

As by default, time intellegence is enabled so the dates are automatically viewed as an heirarchy.

If you want to have single column of date in your visualisation, you can change the settings in your visualisation pane to use date as below:

PC2790_0-1652422142526.png

 

And if you want to remove this hierarchal structure all together, 

Go to  File --> Options and Settings --> Options --> Current File -> Data Load and turn  off 'Auto Date/Time' (under Time Intelligence)

But I would suggest to have it and change the view fro your visualisation base don your requirement

Absolute legend.  I'm learning where microsoft hides all the display functionality!  Thanks for pointing this out, really appreciate it.

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.