I have worked on an issue where one of the customers was unable to connect to Power BI through XMLA endpoint using SQL Profiler.
The error message looks like below:
To overcome this error, follow the steps below:
- Open SQL Profiler, select Authentication method as 'Azure Active Directory - Universal with MFA'
- Make sure you enter the database name in connection properties and add Database name under ‘Connection Properties’ tab(Specify a dataset (database) in your workspace. In the Connect to Server dialog, click Options > Connection Properties > Connect to database, enter the dataset name).
- Make sure to enable XMLA endpoint in 'Read Write' mode and have access to database/dataset that was specified in previous point.
- In the Admin portal, click Capacity settings > Power BI Premium > Capacity name.
- Expand Workloads. In the XMLA Endpoint setting, select Read Write.
Author: Srishti Sharma
Reviewer: Mounika Narayana Reddy
Updated 6 years ago
Version 10.0monaraya
Microsoft Employee
Joined March 11, 2019
Power BI Community Blog
On this blog you will find articles, guides and information created by our community members and, from time to time, roundups and community news.
If you are interested in becoming a community blog author, send a private message to Natalie_iTalent. An overview of the community blogs can be found here.