Showing results for 
Search instead for 
Did you mean: 

Fabric is Generally Available. Browse Fabric Presentations. Work towards your Fabric certification with the Cloud Skills Challenge.

Helper IV
Helper IV

Untyped Data in Dataflow

It appears this issue cleared itself though no idea how/why; I'm curious if anyone else has seen it.


I created a dataflow from a SQL DB and for the initial set of tables it worked pretty much fine first time. I came to add a new query to another table and while it seemed to read the table OK, when I've created some steps in the query it reported that my flow contained 'untyped data'. And yet every column has a data type. it's been presenting the error for the last 2 days of attempting to get it working and then I get an error when trying to load the query (although it actually does add it because its still there when I browse back to the dataflow page, and recovers from the cache).


Suddenly today it seems to have worked without issue. Ayone aware of why this might have happened in case I can avoid issues in future?

Helper III
Helper III

HI there,


I have seen the same issue. I had unytped columns, complex column and in the end unnamed columns.


I am reading csv files from a Sharepoint folder in a dataflow and combine these. It worked in the past and suddenly I got the error.

I got rid of untyped columns and complex columns by specifically assigning datatypes, even though that didn't seem to be necessary before.

The unnnamed column was created because the most current csv file (Exports from multi-site ERP systems) suddenly had an additional column. This column had data in the csv file, yet somehow importing it in a dataflow it brought up no data or column name (probably because there was a mismatch between the older and the new files?)

I didn't pick up on that until I cross checked the csv file.


Creating a new dataflow reading in only the new file with the new column, I didn't have to assign datatypes again and got a named column with data....


Root cause in my case was the change in the input files.


Community Support
Community Support

Hi @shill1000 


Sorry, I can't replicate your issue in my side, I'd suggest you rasing your problem to support team for better advice.

Support Ticket.gif


Community Support Team _ Dina Ye
If this post helps, then please consider Accept it as the solution to help the other members find it more

1) I was canvassing the group to see if anyone had seen this, not reporting it as an issue.

2) If I can't replicate it what's the point of logging a ticket?


If I see a recurrence I'll consider logging a ticket, but in the meantime I'm not markign this as solved as you haven't solved anything.

I've just encountered this error message today and hence came across your post in search for answers.
My experience - I reviewed the data type for each column, and after changing 'ABC123 (Using locale...)' to 'ABC (Text)', the error seemed to have been resolved.

Thank you! I've just been having the same problem which has been puzzling me ALL morning. Just changed the data types from ABC123 (Using locale...) to Text or number only and worked a treat

Helpful resources

PBI November 2023 Update Carousel

Power BI Monthly Update - November 2023

Check out the November 2023 Power BI update to learn about new features.

Community News

Fabric Community News unified experience

Read the latest Fabric Community announcements, including updates on Power BI, Synapse, Data Factory and Data Activator.

Dashboard in a day with date

Exclusive opportunity for Women!

Join us for a free, hands-on Microsoft workshop led by women trainers for women where you will learn how to build a Dashboard in a Day!

Power BI Fabric Summit Carousel

The largest Power BI and Fabric virtual conference

130+ sessions, 130+ speakers, Product managers, MVPs, and experts. All about Power BI and Fabric. Attend online or watch the recordings.

Top Solution Authors