Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
Anonymous
Not applicable

The remote certificate is invalid according to the validation procedure when trying to log in.

Hello everyone.

 

I am having an issue connecting to my data source from the app.powerbi with the intention of having the data constantly updated. I want to connect to my data warehouse, which is in PostgreSQL. The error that I have is the following:

 

Failed to update data source credentials: An error happened while reading data from the provider: 'The remote certificate is invalid according to the validation procedure.'

 

I managed to connect from the desktop APP, which I had the same problem but I solved it by turning off the encrypted connection because we do not use SSL and worked. I edited the following in the data source in PBI Desktop:

 

Screenshot 2020-06-23 at 16.59.31.png 

 

But then, in order to set the schedule refresh in the web app, I try to log in again to set it up and I have the issue again: 

 

 Screenshot 2020-06-23 at 17.01.00.png

 

Is there a way to do the same that I did in PBI desktop but in the web app and disable the encryption or any other way to make this work? 

 

 

Thank you so much!

4 REPLIES 4
v-deddai1-msft
Community Support
Community Support

Hi @Anonymous ,

 

Have you republish the report after you uncheck the encrypt connection in Power BI desktop?Please try to republish it.

 

And please refer to https://community.powerbi.com/t5/Desktop/The-remote-certificate-is-invalid-according-to-the-validation/td-p/531475 to get ssl connection worked.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Best Regards,

Dedmon Dai

Anonymous
Not applicable

Hello @v-deddai1-msft.

 

I even created new reports for testing but nothing works! We also installed SSL into our datawarehouse and also did not work, with and without encrypted connection tick on or off. I also installed the certificate into my windows system. And nothing. 

 

The thing, is if the connection is not encrypted, I cannot set automatic updates of the data for the other people of the company that want to see the reports. 

 

Is any way to have this connection working, with the automatic updates, WITHOUT using a gateway?

 

It's just connecting a DB to PBI... I really do not understand why this is happening. 

 

Thanks.


Ricard

This worked for me...

Install ODBC
Install the ODBC driver for the DB you are trying to connect to. In my case, I had to install the ODBC drive for PostgreSQL Unicde(x64). You can get the msi here.  In Windows open the ODBC Data Source Administrator by going to C:\Windows\SysWOW64 and click twice on odbcad32.exe this will open the 64bit version even though in the title it says (32-bit). Choose Add and choose the ODBC driver you installed. Provide the information and credentials for the DB you are wanting to connect to. You should see the ODBC driver show up in the list of User Data Sources. I also added it to the System DSN sources as well for good measure. 
In Power BI
In Power BI, Get Data> More > Other > ODBC and select the ODBC driver you installed. You will then be able to select the table you wish to connect to. 

I am facing the same issue, everything works on PBI desktop, but got the remote cert issue after publishing. 

@Anonymous did you solve it eventually? 🙂 

 

Updates:

Sovled the problem by adopting the on-premises data gateway.

 

Details:

 

When you connect to a database using an encrypted connection, the server sends you a certificate (typically a self-signed certificate).

This certificate is clearly trusted by your Power BI Desktop installation, as it allows you to make an encrypted connection, and retrieve data.

This certificate is not trusted by the servers running the Power BI Service, which is why this error message is shown.

Your best option is to use an On-Premises Data Gateway to connect to this PostgreSql server, and add the certificate into the Trusted Root store on the Gateway machine. The links referenced in the summary for this issue show how to do that.

Other options, which I  include for completeness (but do not recommend), include:

  1. Convince the Power BI Service team to trust your certificate across their servers (unlikely, but possible if this is an Azure SaaS PostgreSql server. But it will take time)
  2. Stop using encrypted connections (Unsafe, and IT will yell at you)
  3. Configure your PostgreSql server to use a certificate that has been signed by one of the Certification Authorities which are trusted in Windows by default (this costs money).

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors