Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Regular Visitor

Right Click not working


I am trying to Right Click to drillthrough. When I use Desktop, it works fine. When I delpoy to Service, I get no right click menus appear. I have the same symptoms on two different reports. They were working fine a couple of days ago and have subsequently stopped working with any changes.

I'm using Matrix visualisations.

I have checked in Edge and Chrome and get the same result in both. 


Any ideas?




Regular Visitor

I checked this morning. This is now working as expected. Something, somewhere was fixed, but not by me! 

View solution in original post

Advocate II
Advocate II

This issue still exists unfortunately.


I'm hoping for the same solution as the poster had (i.e. that is goes away by itself), but it appears to me this is what Microsoft claims should not be possible, the result of a corrupt file. The dataset consists of many separate files (XML / CSV / XLS(X)) from a couple of sources, all cleaned and combined into one specific table. This is modelled together with data from a SQL Server instance.


I've had problems with this same report before where one critical error in one of the files, all transformed with the help of the auto-generated function, based on the transformations of an example report, would delete EVERY source in the query editor that is located directly or in a subfolder under the same top folder as where that auto-generated function would reside, followed by a long list of suddenly "Missing" tables when trying to load the data.


Other strange behaviour of this same file is that:

- after changing queries in the query editor and refreshing and republishing the report, the online version, would initially show the changes I made including the refreshed data, yet after clicking anything in the report, it would change itself (online) to revert to the old version. Not even waiting a while or refreshing all visuals will change this. A manual refresh also didn't solve the problem, however, the scheduled refresh two days later did.

- Also, reopening the file in PBI Desktop, it would ask me again to load or discard the changes made in the query editor (which I already loaded before refreshing and republishing).

- then, the reason I'm writing this here is that even though the scheduled refresh now does include the changes and new data, it is not possible to right click the data in the tables (which worked like a charm before and nothing changed there) to drill-through to different pages in the same report. The menu simply doesn't show.

- and finally, I see that a shape map doesn't fill anymore, which it always did before.


My best guess is that this is related to the amount of memory required for this type of data loading. I'll test with less data and see if this will solve the problem. I'm guessing the only real solution is probably to reorganize the flow on the front-end and just pull all the data from the SQL Server database.





p.s. just before I'm posting this, I clicked F5 in the browser (Edge) and now it works? It seems like a hickup, but it's definitely strange behaviour.

Not applicable

My users are reporting the same issue.  We have a report that has been live for 2 years but now right click does not work on the matrix visuals.  If you right click on the report page which only has charts, the pop up menu appears and you can drillthrough.  However, this functionality has disappeared on the the report pages which contain matrix visuals.  I have tested in all browsers.

@v-alq-msft The reports are working as expected again in the PBI Service as of 8:00am CST today.


@Anonymous You might check again on your end and let us know the result?

@BIstehtI had a look this morning via my corporate BI services. I am still getting the same issue as reported in orginal post. I now see in the  dark grey popup "Right-click to drill through". I think this is new.  

The right click drill action through is still not working for me.

Regular Visitor

I checked this morning. This is now working as expected. Something, somewhere was fixed, but not by me! 

Community Support
Community Support

Hi, @willj 


I have tried to drill through with a matrix visual. The result is that it appears normal both in Power BI Desktop and Service. I can't reproduce your scenario. For further information, please refer to the official document .


Best Regards



If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-alq-msft I am getting a simliar result. I have four pages with matrix visuals that contain drillthrough on the same fields. Two of the pages (matrices) work as expected. Right-click does NOTHING on the other two. No menu appears opon right-click. I tested Chrome, Edge (Chrome), Brave and Firefox, with the same result across all of them. Note that this report is 100% functional in the Desktop version.

Super User
Super User

I checked and I can right-click and drillthrough in the Service but I don't have a matrix visual to test with.

@ me in replies or I'll lose your thread!!!
Instead of a Kudo, please vote for this idea
Become an expert!: Enterprise DNA
External Tools: MSHGQM
YouTube Channel!: Microsoft Hates Greg
Latest book!:
The Definitive Guide to Power Query (M)

DAX is easy, CALCULATE makes DAX hard...

Helpful resources

Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City


Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors