Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
chapnick
New Member

Power BI datasets not showing in Excel, endorsed not showing at the top, search not working

Hey everyone, my organization is having issues when trying to use Excel to get data from a Power BI shared dataset. We have many users that open Excel, go to Get Data > From Power Platform > From Power BI, to load the list of Power BI datasets they have access to.

This list and its search worked fine in the past, but looks like it has been updated. This update seems to have broke or downgraded multiple things. 

  1. Our endorsed Power BI datasets no longer show at the top of the list. They are now buried deep in the list. Is this by design? How do we get our endorsed datasets to show at the top? What order is this list in?
  2. Search does not work, or brings back invalid results. Our users are trying to use the search box at the top to find the name of a Power BI dataset. This used to work fine in the past, but after the update the search results seem random. Many of the datasets returned are not related to the search text at all, while other items that should be returned are not showing up.

Is there anything we can do on our end to fix these issues? Are there any workarounds (besides using Analyze in Excel)? Are these known issues with Microsoft? Many of our users are rightfully getting frustrated with this feature. Thanks for you time!

tempsnip.png

10 REPLIES 10
Thias
Frequent Visitor

I have this issue today. 

Is there any solution available, which would solve the problem? Most of my dataset are available. But 2 just do not appear in the search pane. I am admin of the workspaces, so should be no issue with permissions. 

Thias_0-1708502395235.png

 

Chenp
Frequent Visitor

I was facing the same issue today and a couple datasets just not sppear in the search panel. I am also admin of the workspace. I later tried on another admin's laptop and found out that it may have something to do with the excel version. I googled our excel versions and found out another admin's excel is semi-Annual Enterprise Channel and my excel is Current Channel. I have no idea what they mean but I know we both have the same accesses and license types. In fact, I am the owner of the dataset but I cannot access and another admin can. This makes me believe it is the excel version issue. I cannot confirm this unless I have semi-Annual Enterprise Channel but it is a difficult process for my org to install this version on my laptop, so I am looking for other workarounds to overcome this.

 

Hi @Chenp 

 

What happens if you try and open it from Excel in OneDrive for Business, does that successfully see the semantic model and allow you to connect?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

@GilbertQ & @chapnick & @Chenp & @chikoo : 
I found a solution but i am really not sure if it is feasible working for you as it is almost to easy to believe. 

 

So if i click on the "Get Data --> From Power Platfomr --> Power BI" I get a random view of datasets. 

Ich checked it with lots of users and with different access rights and every time the list of semantic models appearing was quite confusing. 

Thias_0-1714052312991.png

As described earlier the search for a specific dataset does not help, the screen is empty than: 

Thias_1-1714052370493.png

 

But guess what. If i press the "Enter" button of my keyboard in the search field, it will start searching for semantic models and also find them: 

Thias_2-1714052474193.png

So pressing enter resolved my issue. It also worked for everybody else in the organization. 

Now this is part of our user training 😅

Chenp
Frequent Visitor

@Thias  I cannot mark you as the solution but I tested what you said, it works! lol. I don't remember why I have never thought to press enter....but I was able to find the missing datasets by just pressing "enter" on the keyboard. Thank you.

 

It doesn't becuase I was trying to connect to Power BI reports that were published in the server workspace, not the file that I saved.

 

chikoo
Frequent Visitor

I'm facing the similar issue. Were you able to find any solution for this?

PBI_Queryous
Advocate I
Advocate I

I am experiencing this issue today. I can see some of the Datasets in the workspace, but not all of them. This appears to be a bug of some sort. Annoying and disruptive.

xmarti
Regular Visitor

Hi,

 

We've exactly the same issues -> 100% the same:

- Certified and Promoted Datasets don't appear in the first results

- Random returns based on the search string, with crazy situations where no related terms appear in the name of the Datasets

- The Dataset the user looks for sometimes doesn't appear in the results

 

As explained in the issue, the previous search dialog works fine, but the new one don't.
Any advance at this respect?

 

Thank you!

 

    Xavi M.

GilbertQ
Super User
Super User

Hi @chapnick 

 

I have also had the same challenges you are talking about. What I would suggest is to log a support ticket to see if there is anything that support can do.

 

I would also suggest going to https://ideas.powerbi.com and voting for an idea to improve this.





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.