Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
ShaikMahmad
Regular Visitor

Getting an error while refreshing power bi report.

Hi Team,
 

I'm facing this issue when Power BI report getting refresh. Can you please help me in this case.

 

The amount of data on the gateway client has exceeded the limit for a single table. Please consider reducing the use of highly repetitive strings values through normalized keys, removing unused columns, or upgrading to Power BI Premium.

 

ShaikMahmad_0-1668371586612.png

 

1 ACCEPTED SOLUTION
v-xiaosun-msft
Community Support
Community Support

Hi @ShaikMahmad ,

 

It should be by-design limitation. Actually, the resolution of this issue is exposed in the Error message itself, remove the columns with high cardinality or move to Premium.

Move to Premium:

With Premium capacities, large datasets beyond the default limit can be enabled with the Large dataset storage format setting. But it's cost is high.

Therefore, you can try to remove the columns with high cardinality.

Please follow the steps to find the columns with high cardinality is to use the DAX Studio tool:

1 Connect to the model/PBIX file

2 Go to Advanced -->View Metrics

vxiaosunmsft_0-1669363453250.png

3 Try to remove as much as you can from the columns that have the highest cardinality.

 

Please reference the following links which may be helpful to you.

The amount of data on the gateway client has excee... - Microsoft Power BI Community

Large datasets in Power BI Premium - Power BI | Microsoft Learn

 

Best Regards,
Community Support Team _ xiaosun

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-xiaosun-msft
Community Support
Community Support

Hi @ShaikMahmad ,

 

It should be by-design limitation. Actually, the resolution of this issue is exposed in the Error message itself, remove the columns with high cardinality or move to Premium.

Move to Premium:

With Premium capacities, large datasets beyond the default limit can be enabled with the Large dataset storage format setting. But it's cost is high.

Therefore, you can try to remove the columns with high cardinality.

Please follow the steps to find the columns with high cardinality is to use the DAX Studio tool:

1 Connect to the model/PBIX file

2 Go to Advanced -->View Metrics

vxiaosunmsft_0-1669363453250.png

3 Try to remove as much as you can from the columns that have the highest cardinality.

 

Please reference the following links which may be helpful to you.

The amount of data on the gateway client has excee... - Microsoft Power BI Community

Large datasets in Power BI Premium - Power BI | Microsoft Learn

 

Best Regards,
Community Support Team _ xiaosun

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

aj1973
Community Champion
Community Champion

Hi @ShaikMahmad 

It's abvious that your Data model needs optimisation. If you don't want to go for Power BI Premium because of its cost then for sure you need to verify the size of your tables. Maybe use Direct Query mode is also a good solution.

Regards
Amine Jerbi

If I answered your question, please mark this thread as accepted
and you can follow me on
My Website, LinkedIn and Facebook

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.