Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Reply
emilne
New Member

Gateway Mashup Data Error with Azure Function

I am working on a report that uses an Azure function as a data source. My query reads in two tables from a Sharepoint Excel file, converts them to JSON and then POSTs them to the Azure function via API. The query works in Power BI Desktop without issue, but fails in Power BI online with the following error:

 

Data source error: {"error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","pbi.error" {"code":"DM_GWPipeline_Gateway_MashupDataAccessError","parameters":{},"details":[{"code":"DM_ErrorDetailNameCode_UnderlyingErrorCode","detail":{"type":1,"value":"-2147467259"}},{"code":"DM_ErrorDetailNameCode_UnderlyingErrorMessage","detail":{"type":1,"value":"Web: Request failed: SharepointPath/MinisterCountry_Lookup_xlsx/_api/contextinfo"}},{"code":"DM_ErrorDetailNameCode_UnderlyingHResult","detail":{"type":1,"value":"-2147467259"}},{"code":"Microsoft.Data.Mashup.ValueError.DataSourceKind","detail":{"type":1,"value":"Web"}},{"code":"Microsoft.Data.Mashup.ValueError.DataSourcePath","detail":{"type":1,"value":"SharepointPath/MinisterCountry_Lookup_xlsx/_api/contextinfo"}},{"code":"Microsoft.Data.Mashup.ValueError.Reason","detail":{"type":1,"value":"DataSource.Error"}}],"exceptionCulprit":1}}} Table: Response.
Cluster URI: WABI-CANADA-CENTRAL-redirect.analysis.windows.net
Activity ID: 0dab9edb-b0a7-4497-9ad6-0905b7e9e035
Request ID: 92c96638-d84a-bcc0-d3ab-02849cbbd4f5
Time: 2024-04-15 14:39:14Z

The Azure function is Anonymous and connected via a VNET gateway and the Sharepoint file is set at the "Organizational"
privacy level.

 

I'm pretty sure the issue is not with the Sharepoint file itself, since I have tried removing the file in the message and the same error appeared with a different Sharepoint source. I also tried replacing the file with a different copy with no luck. When I separated the Sharepoint source and Azure function source into separatequeries, I received a Formula.Firewall error. Setting the privacy levels to "Private" also resulted in a different error: "accessing data sources that have privacy levels which cannot be used together".
The Azure function and gateway seem to be working on their own as well, since when I hardcoded some dummy data into the query and removed all Sharepoint sources, the dataset refreshes with no issue, so I think the issue is something to do with the combination of the two data sources.

 

How can I link to an Azure function without getting this error?

1 REPLY 1
v-xiandat-msft
Community Support
Community Support

Hi @emilne ,

The error related to privacy levels indicates a conflict between the data sources' privacy settings. Since setting the privacy levels to "Private" resulted in a different error, it's important to ensure that both the SharePoint source and the Azure function have compatible privacy levels set. For more detailed guidance on configuring privacy levels.

As you mentioned receiving a error upon separating the SharePoint source and Azure function source into separate queries, this suggests an issue with combining data from these sources due to privacy level restrictions or the way the queries are structured. A potential workaround is to use two separate queries to load data from each source independently into Power BI and then merge or append the data within Power BI. For guidance on merging queries

Best Regards,

Xianda Tang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

Top Solution Authors