Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
NJCLIFFORD
Frequent Visitor

Error connecting to data

Howdy, 

Created a report linking to two already existing datasets and a few tables off an import from Excel.

 

On desktop the visualizations using existing datases are showing ok, but when I publish and view online I get "

Couldn't load the data for this visual

Couldn't retrieve the data for this visual. Please try again later."

 

I am not sure where to start as am pretty new to this.

 

Any pointers?

Thanks

Nicjk

1 ACCEPTED SOLUTION
v-mengzhu-msft
Community Support
Community Support

Hi @NJCLIFFORD,

For this error,

vmengzhumsft_0-1659603487386.png

please check the gateway connection in dataset settings, configure gateway for your data source.

At the same time, you said when you load my report in BI Service it has an error 'There is no available gateway', I notice that you have a excel file data source in your report, you should also configure gateway for it.

Simply put, your report is a composite data source and you need to configure the gateway to the local data source first. For more details, please refer to this doc:

Merge or append on-premises and cloud data sources - Power BI | Microsoft Docs

 

Best regards, 

Community Support Team Selina zhu 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly 

View solution in original post

4 REPLIES 4
v-mengzhu-msft
Community Support
Community Support

Hi @NJCLIFFORD,

For this error,

vmengzhumsft_0-1659603487386.png

please check the gateway connection in dataset settings, configure gateway for your data source.

At the same time, you said when you load my report in BI Service it has an error 'There is no available gateway', I notice that you have a excel file data source in your report, you should also configure gateway for it.

Simply put, your report is a composite data source and you need to configure the gateway to the local data source first. For more details, please refer to this doc:

Merge or append on-premises and cloud data sources - Power BI | Microsoft Docs

 

Best regards, 

Community Support Team Selina zhu 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly 

NJCLIFFORD
Frequent Visitor

Howdy, thanks for the quick response...

I have gone to Settings -> Manage Gateways -> Data Sources and there are a lot of names under there with status etc

I have found the two there that match the names of the Data Sets I am using, and the Status on them when I click the icon shows as Unknown Error - see image below.

Capture.PNG

gauthamboppana
Solution Specialist
Solution Specialist

@NJCLIFFORD  - Have you checked the gateway connections for the dataset?  If they aren't mapped, then you need to update the gateways. Let me know if you have any questions.

gauthamboppana_0-1659430948889.png


Did I answer your question? Mark my post as a solution! If not, please feel free to ask me.

Also, I would ❤ Kudos if my solution helped.  It is a token of appreciation!

Thank you very much !

 

NJCLIFFORD
Frequent Visitor

Sorry, did not include much info in that...

On Power BI Desktop, I have tried going to the Transform Data / Clear Permissions and that did not seem to fix the problem.

 

Also, on the Power BI Service, when I look at the Lineage view it has the two existing data sets coming from ODBC connection into the dataset with the same name as my report. When I go to settings for my dataset it has an error 'One or more cloud data sources for this dataset have been deleted. Recreate cloud data sources (link)'  Clicking the link does nothing.

 

When I look at the two existing datasets, they are refreshing successfully as there is a report for each of the ODBC datasets and they are loading fine in the Power BI Service.

 

Also when I load my report in BI Service it has an error 'There is no avaiable gateway'

 

I am confused as to why the Desktop is working ok??

 

Thanks again

Noob Nick

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors