Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
Anonymous
Not applicable

Data source error: Information is needed in order to combine data;Information about a data source is

Hi,

 

I started getting this error on one a couple of my dataset refreshes. It refreshes fine in the desktop. Any ideas on what could be causing this?

 

Data source error: Information is needed in order to combine data;Information about a data source is required.. The exception was raised by the IDbCommand interface.

1 ACCEPTED SOLUTION
v-yueyunzh-msft
Community Support
Community Support

Hi, @Anonymous 

According to your error message, I checked the relevant problem documents, and the reason is due to the privacy level of the data source configuration.

You can follow my steps below to troubleshoot if the issue is caused by inconsistent "Privacy setting" settings:

(1) You can open the corresponding PBI desktop local file first, and go to the option "Option and Settings-Options" to open this option:

vyueyunzhmsft_0-1662626847400.png

 

(2) Then you go to "Data Source Settings" and make sure that the "Privacy setting" settings of all data sources connected to your dataset are consistent:

vyueyunzhmsft_1-1662626847406.png

 

(3) After confirming the consistency, you can perform a desktop data refresh to ensure success.

(4) After the refresh is successful, you can republish to and try to reconfigure the data source definition for the data source of the related dataset to ensure that the "Privacy level" configured on the Serive is consistent with that of the Desktop:

vyueyunzhmsft_2-1662626847412.png

 

        

vyueyunzhmsft_3-1662626847414.png

 

If the above methods cannot help you troubleshoot the problem, you can provide your detailed error information so that we can better help you solve the problem.

 

Best Regards,

Aniya Zhang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

View solution in original post

6 REPLIES 6
enakaleah
Frequent Visitor

I'm getting this all of a sudden. Files, during desktop design, are set to ignore privacy levels. then publish to online service. check connections again to make them all "none" privacy levels. PowerBi report uses an odata connection to a sales pos and web url to excel files stored in one drive, using oauth login. and all connection privacy levels are set to none, both the odata and oauth. This setup worked for 2+ years, files refreshed daily, and sent report to multple departments. Today it has broken and I dont know why I keep getting this refresh error: 
Data source error: Information is needed in order to combine data. Please specify a privacy level for each data source.;Information about a data source is required.. The exception was raised by the IDbCommand interface. Table: Sales.
Cluster URI: WABI-US-CENTRAL-A-PRIMARY-redirect.analysis.windows.net
Activity ID: 673bf96a-3004-4013-a369-57d7e584c75f
Request ID: 512c520e-1f12-565e-f81e-1732faf3e234
Time: 2023-11-03 21:35:23Z

v-yueyunzh-msft
Community Support
Community Support

Hi, @Anonymous 

According to your error message, I checked the relevant problem documents, and the reason is due to the privacy level of the data source configuration.

You can follow my steps below to troubleshoot if the issue is caused by inconsistent "Privacy setting" settings:

(1) You can open the corresponding PBI desktop local file first, and go to the option "Option and Settings-Options" to open this option:

vyueyunzhmsft_0-1662626847400.png

 

(2) Then you go to "Data Source Settings" and make sure that the "Privacy setting" settings of all data sources connected to your dataset are consistent:

vyueyunzhmsft_1-1662626847406.png

 

(3) After confirming the consistency, you can perform a desktop data refresh to ensure success.

(4) After the refresh is successful, you can republish to and try to reconfigure the data source definition for the data source of the related dataset to ensure that the "Privacy level" configured on the Serive is consistent with that of the Desktop:

vyueyunzhmsft_2-1662626847412.png

 

        

vyueyunzhmsft_3-1662626847414.png

 

If the above methods cannot help you troubleshoot the problem, you can provide your detailed error information so that we can better help you solve the problem.

 

Best Regards,

Aniya Zhang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

This actually doesn't make sense. In your solution, you mentioned to keep the Privacy Levels consistent between the desktop and service, but it's showing the Desktop Privacy Level set to "None" and the Service Privacy Level set to "Organizational".

 

Can you explain how this is supposed to be consistent?

Thank you. This was so helpful in solving my problem

Thank you, this worked for me. Although, I had to upgrade the gateway (a new version was available) before I was able to save changes at step 4 

Anonymous
Not applicable

Thank you!

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors
Top Kudoed Authors