Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
mlmpowerbi
New Member

Cannot connect file sources to dataset : Could not find a part of the path

Everything worked fine using PBI Desktop and PBI-Service when I installed the Gateway in Personal Mode.

 

However, since I installed the standard Gateway the connections to some files don't work, The exact error message is: 

 

--------------------------------------------------------------------------------------------------------------------------------------

Unable to connect: We encountered an error while trying to connect to . Details: "We could not register this data source for any gateway instances within this cluster. Please find more details below about specific errors for each gateway instance."

 

Unable to connect to the data source undefined.

-2147467259

 

Could not find a part of the path 'P:\TEST-DLF\Sales\Operations & Sales\Sales\00_Folder\Folder- Power BI\_anotherfolder\SourcePowerBI\my-sales-team.xlsx'.

------------------------------------------------------------------------------------------------------------------------------

I have access to P: from my computer and, as I said, never had a problem with these same files in PBI Desktop or Gateway (Personal mode).  Also, the standard Gateway runs correctly on my machine and I had no problem in connecting other data sources. 

 

Is there some special character in the path that could interfere with the connection?

If not, what could be the origin of this problem?

 

1 ACCEPTED SOLUTION
v-yetao1-msft
Community Support
Community Support

Hi @mlmpowerbi 

I restored the same path as yours, except the disk is different, the rest is the same. But I set it up successfully, so there is no problem with the special characters you mentioned. Let’s troubleshoot the problem step by step .

Ailsamsft_0-1624933575135.png

(1)Through the error ,it seems like standard gateway is not updated , please check the version for your gateway and update it to the lastest one .

Ailsamsft_1-1624933575136.png

(2)If you have updated your gateway to the lastest one ,please check your datasource path in Data Source Settings in Desktop , make sure the path in Data Source Settings is same with the path in Manage gateways .

Ailsamsft_2-1624933575138.png

Ailsamsft_3-1624933575140.png

Looking forward to your reply .

 

Best Regards

Community Support Team _ Ailsa Tao

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

View solution in original post

3 REPLIES 3
v-yetao1-msft
Community Support
Community Support

Hi @mlmpowerbi 

I restored the same path as yours, except the disk is different, the rest is the same. But I set it up successfully, so there is no problem with the special characters you mentioned. Let’s troubleshoot the problem step by step .

Ailsamsft_0-1624933575135.png

(1)Through the error ,it seems like standard gateway is not updated , please check the version for your gateway and update it to the lastest one .

Ailsamsft_1-1624933575136.png

(2)If you have updated your gateway to the lastest one ,please check your datasource path in Data Source Settings in Desktop , make sure the path in Data Source Settings is same with the path in Manage gateways .

Ailsamsft_2-1624933575138.png

Ailsamsft_3-1624933575140.png

Looking forward to your reply .

 

Best Regards

Community Support Team _ Ailsa Tao

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

v-yetao1-msft
Community Support
Community Support

Hi @mlmpowerbi 

Until now , you can still connect to these files in Desktop and Gateway(personal mode) and use the data from files normally, right ?

If yes, please check the data source settings in your Service .We need add data source in Manage Gateways ,like this

Ailsamsft_0-1624846883655.png

The Data Source Type is File, and enter full path for your file in Full Path. Enter your Windows authentication information and Apply. IF it shows connection successfully ,that means you have configured your datasource correctly .

Then go to dataset settings ,in Gateway connection ,map your dataset and your datasource .Then manually refresh and view the refresh record in Refresh history .

Ailsamsft_1-1624846883660.png

Ailsamsft_2-1624846883662.png

Best Regards

Community Support Team _ Ailsa Tao

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Hello @v-yetao1-msft 

 

thank you for your help.  It is what I am trying to do but I get the error message about the path. I reviewed thousands times the path and it is correct. Also. if I put the file in the C:\ drive it works fine. But when I try with the P:\ it doesn't work. My computer has access to the P:\ drive and there was no issue when using the same file and the same path in PBI Desktop or the Gateway on personal mode.

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Power BI Header Change

Power BI Header Update

Read about the exciting updates for the Power BI forum.

Top Solution Authors
Top Kudoed Authors