Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
mellolr
Regular Visitor

XML Dataset Error There was a problem getting data from the Report Server Web Service

I have a XML dataset that works in report builder, but on report server gives the error below. Any ideas what could be the problem? The datasource on the report server connects successfully. 

An error has occurred.

The data set could not be processed.

There was a problem getting data from the Report Server Web Service.

 

The SQL View EecutionLog just says rsProcessingAborted

 

RSPortal Log entry:

2022-04-11 16:36:28.8988|INFO|36|Received request POST /api/v2.0/Datasets(4c0ac448-55fe-4d49-ab76-7fd79566a8ff)/Model.GetData| RequestID = s_272732e5-f1ae-4a29-bf59-46c6d3870392
2022-04-11 16:36:29.6644|ERROR|36|There was a problem getting data from the Report Server Web Service: System.Web.Services.Protocols.SoapException: An error has occurred during report processing. ---> Microsoft.ReportingServices.ReportProcessing.ProcessingAbortedException: An error has occurred during report processing. ---> Microsoft.ReportingServices.ReportProcessing.DataSetExecutionException: The execution failed for the shared data set 'DataSet1'. ---> Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: Query execution failed for dataset 'DataSet1'. ---> Microsoft.ReportingServices.DataExtensions.XmlDP.XmlDPException: Failed to prepare web request for the specified URL. ---> System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
at Microsoft.ReportingServices.Library.ReportExecution2005Impl.InternalRender(String Format, String DeviceInfo, PageCountMode pageCountMode, Stream& Result, String& Extension, String& MimeType, String& Encoding, Warning[]& Warnings, String[]& StreamIds)
at Microsoft.ReportingServices.Library.ReportExecution2005Impl.Render(String Format, String DeviceInfo, PageCountMode pageCountMode, Byte[]& Result, String& Extension, String& MimeType, String& Encoding, Warning[]& Warnings, String[]& StreamIds)
at Microsoft.ReportingServices.WebServer.ReportExecutionService.Render2(String Format, String DeviceInfo, PageCountMode PaginationMode, Byte[]& Result, String& Extension, String& MimeType, String& Encoding, Warning[]& Warnings, String[]& StreamIds)| RequestID = s_272732e5-f1ae-4a29-bf59-46c6d3870392
2022-04-11 16:36:29.6644|INFO|61|Sending response. Response code UMHS\mellol 422, Elapsed time 0:00:00.7642824| RequestID = s_272732e5-f1ae-4a29-bf59-46c6d3870392

1 ACCEPTED SOLUTION
v-xiaoyan-msft
Community Support
Community Support

Hi @mellolr ,

 

Please see if this article below helps you with your question.
It describes in detail how to Enable TLS 1.2 protocol for Reporting Services with custom .NET application 

 

Also,you may check this :How to enable TLS 1.2 on clients 

 

Best Regards,
Community Support Team _ Caitlyn

If this post helps then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-xiaoyan-msft
Community Support
Community Support

Hi @mellolr ,

 

Please see if this article below helps you with your question.
It describes in detail how to Enable TLS 1.2 protocol for Reporting Services with custom .NET application 

 

Also,you may check this :How to enable TLS 1.2 on clients 

 

Best Regards,
Community Support Team _ Caitlyn

If this post helps then please consider Accept it as the solution to help the other members find it more quickly.

mellolr
Regular Visitor

When I ran wireshark on the PBIRS and noticed that Power BI was using TLS 1.0 to call the web service, which is not allowed on our web server. To test it, I changed the web service from HTTPS to HTTP and it worked. 

How do I force PBIRS to use TLS1.2 when calling the web service? The PBIRS is already setup to only accespt TLS1.2.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.