Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
dustinn
Resolver I
Resolver I

Report Server with AD Application Proxy stuck at loading

We managed to connect our Report Server into Active Directory Application Proxy so it is accessible outside the company's network. Almost everything works fine except for it is stuck on loading the data when I'm viewing the report (both for browser and mobile app)

 

Report Server: August 2018

Windows: Windows Server 2012 R2

 

 

Did I miss a something/need to know? Or Do I need to upgrade to Windows Server 2016 in order to make it work (see gabil's post)? 

 

Thanks.

Stuck at Loading.png

 

 

 

 

 

10 REPLIES 10
RickyRhys
Regular Visitor

I'm experiencing the same issue now.
I'm guessing it relates in some way to the delegated access to the ReportDB...
Did anyone manage to find a solution?

i had the same issue, since i update SSRS with september version.

After investigate it's a probleme about CORS access. No credentials are sending trought  MSapp proxy to the Report Server ( code error  (0x8009030e) ) 
if someone have any clues it will be really welcome.

 

 

For us, the issue was the URL that we used in the App Proxy.

If you are accessing the report server directly, you use http://reportservername/reports

but you need to drop off the /Reports in the app proxy and direct to http://reportservername

This resolved the issue for us.

Hi RickyRhys,

Indeed it was that i found it yesterday evening. 
It's also solved the probleme in our Side.
Thank you for your confimation.

DmitryK
New Member

Does anybody fixed it? Also stucked with publishing.

aspireyas
Regular Visitor

Am stuck at the same place. Is there a solution?

I have the dummy Mobile reports working on desktop which were built with default template, although it takes hours to refresh data on Mobile App.

 

Only the dashboards created with some data or sample dashboards from Obvience are not loading when published over internet using AD App proxy.

dustinn
Resolver I
Resolver I

I still can't make it work after upgrading to Windows Server 2016. Anyone could help me out?

Any luck? I have the same issue.

I had the same problem - in my case it's a SSRS server which is basically the same thing. 

  • I had included the "/reports" portion in the Internal URL, so that had to be removed. Thanks to @RickyRhys for that tip.

Looking back it makes perfect sense: The actual report is rendered in an iframe whose URL is /ReportServer/Pages/ReportViewer.aspx. So having the /reports section will screw that part up.

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Kudoed Authors