Showing results for 
Search instead for 
Did you mean: 
Not applicable

Filter report with URL query paramaters

I cannot get the newly added feature to filter reports through URL query paramters to work.


I have created a report with a manually entered table with the name Table1. Columns are Column1 and Column2. In these columns i enter the vauels (1, A), (2, B), (3, C) and (4, D). I add a simple table visual the show all rows from Table1. Then I pulish the report on my updated report server and enter the URL: http://server/reports/powerbi/TestReport?filter=Table1/Column1 eq 1. All lines are showing. I allso tried surrounding the 1 in single quotes but I get same result.


Help needed!


Hi @Anonymous,


I really dont know if that is the case, but I had some problems with visualizations that were solved after I cleaned the Chrome's browser cache.


Filters here works with Chrome...

View solution in original post

Resolver II
Resolver II

hello @Anonymous,


please be aware of the following limitations:



The same restrictions that apply to the Power BI service apply to the Report Server as well:
- Table and Field names are case sensitive, value is not.
- Fields that are hidden from report view can still be filtered.
- Value has to be enclosed with single quotes.
- Field type has to be string.
- Table and field names cannot have any spaces.

Community Support
Community Support

Hi @Anonymous,


The issue should be the Column1 data type is number, while it requires field to be string. You can filter via this URL:

http://server/reports/powerbi/TestReport?filter=Table1/Column2  eq 'A'


For more infomration, see:


Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Not applicable

Thanks but this did not solve the problem. I changed the name of the tabel to T and the columns to C1 and C2. Both columns are type text.


I have tried this:

http://rerver/reports/powerbi/TestReport?filter=T/C1 eq '1'

http://rerver/reports/powerbi/TestReport?filter=T/C2 eq 'A'

http://rerver/reports/powerbi/TestReport?filter=T/C2 eq 'a'


Nothing seems to work. Im begining to doubt I have installed the latest version of PBI Report Server. How do I check that?

well, your sintax seems to be corect. I just tested in one of my reports and here it works well.

You can check the version on the ? menu from the report portal:



Not applicable

Here is my version:

2017-11-07 10_42_04-Test2 - Power BI Report Server.png

Seems like you have a more reacent version. Will try to download and install the latest version.

Not applicable

Now I have the latest version of the server installed and still unable to filter. I have now tested to import a small table and filtered on that. Nothing works! In Chrome...


I really need this feature for ALL browsers!


Report ServerReport ServerQuery EditorQuery Editor2017-11-07 11_23_36-Test2 - Power BI Report Server - Internet Explorer.png

Hi @Anonymous,


I really dont know if that is the case, but I had some problems with visualizations that were solved after I cleaned the Chrome's browser cache.


Filters here works with Chrome...

Not applicable

Clearing the cache in Chrome did the trick! Thanks @muchinski

Helpful resources

PBI Sept Update Carousel

Power BI September 2023 Update

Take a look at the September 2023 Power BI update to learn more.

Learn Live

Learn Live: Event Series

Join Microsoft Reactor and learn from developers.

Dashboard in a day with date

Exclusive opportunity for Women!

Join us for a free, hands-on Microsoft workshop led by women trainers for women where you will learn how to build a Dashboard in a Day!

MPPC 2023 PBI Carousel

Power Platform Conference-Power BI and Fabric Sessions

Join us Oct 1 - 6 in Las Vegas for the Microsoft Power Platform Conference.