Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
siddhant-croma
Frequent Visitor

Excel data refresh error

My query is simple. I am new to PBI. I want to create a report based on excel file which is currently stored locally and on my One drive. This excel file would be modified later. So my report should also auto refresh accordingly. 

 

I have published the report on the server. Now in my workspace, I can see seemantic model. When I click on the 'refresh now' button next to the semantic model name, it shows me a red colored notification icon. The text details of it is like this- 

 

Scheduled refresh has been disabled.

Please try again later or contact support. If you contact support, please provide these details.

Data source errorScheduled refresh is disabled because at least one data source is missing credentials. To start the refresh again, go to this dataset's settings page and enter credentials for all data sources. Then reactivate scheduled refresh.
Cluster URIWABI-SOUTH-EAST-ASIA-B-PRIMARY-redirect.analysis.windows.net
Activity ID00eebf20-d2c1-4c4e-bf8d-fe355ea6ff3c
Request ID4a0dd96b-1e37-f6cd-a706-b990e3fd0f82

 


I then went to setting of the semantic model and saw error which goes like-

Last refresh failed: 1/23/2024, 5:52:11 PM
Scheduled refresh has been disabled

Data source error: Scheduled refresh is disabled because at least one data source is missing credentials. To start the refresh again, go to this dataset's settings page and enter credentials for all data sources. Then reactivate scheduled refresh.
Cluster URI: WABI-SOUTH-EAST-ASIA-B-PRIMARY-redirect.analysis.windows.net
Activity ID: 00eebf20-d2c1-4c4e-bf8d-fe355ea6ff3c
Request ID: 4a0dd96b-1e37-f6cd-a706-b990e3fd0f82

 


The 'Data sourse credentials' are showing to be greyed out.

 

Please help me 

1 ACCEPTED SOLUTION
v-xiandat-msft
Community Support
Community Support

Hi @siddhant-croma ,

To that option is greyed out. You have to expand the Gateway connection which will then enabled the data source credentials.

 

And then from the error you should be able to update your credentials for your data source.

vxiandatmsft_0-1706074609902.pngvxiandatmsft_1-1706074657925.png

Once you've added these data sources to the gateway, you can set up the data source credentials and it should refresh!

Best Regards,

Xianda Tang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
v-xiandat-msft
Community Support
Community Support

Hi @siddhant-croma ,

To that option is greyed out. You have to expand the Gateway connection which will then enabled the data source credentials.

 

And then from the error you should be able to update your credentials for your data source.

vxiandatmsft_0-1706074609902.pngvxiandatmsft_1-1706074657925.png

Once you've added these data sources to the gateway, you can set up the data source credentials and it should refresh!

Best Regards,

Xianda Tang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Yes. It worked!

 

So the thing which was missing in my case was that I had not installed Personal Gateway. 

 

I installaed it. Logged in. Synched the database. 

Now I am able to refresh the data manually and schedule refresh. 

 

Thanks a lot 🙂

Gayatri_D05
Resolver II
Resolver II

Hi @siddhant-croma ,
Welcome to PowerBI buddy.
It seems that powerbi isnt able to access your data connection to the excel.
When you connected your powerbi to excel was it from your local file or the onedrive file ?
You may want to go with the one drive file.
Also note that the email id you are using for one drive is the same id should be using in data source credentials or atleast have an access to the one drive.

Let me know if this helps. 

Hi Gayatri, 

Thanks for the reply. 

But the problem is not the one which you've described. 

I have created the report on Onedrive excel file. 

I have logged in through same email ID. But the semantic model doesnt refresh itself. Neither does it allow me to refresh manually as scheduled refresh is aparently disabled. 

 

Error text: "Data source errorScheduled refresh is disabled because at least one data source is missing credentials. To start the refresh again, go to this dataset's settings page and enter credentials for all data sources. Then reactivate scheduled refresh."

 

As per the instructions given, I tried opening Semantic data settings and looked for "Data sourse credentials". But that option is greyed out (unavailable to select). 

 

Please refer screenshots to understand better- 

Semantic model setting: Credentials are disabledSemantic model setting: Credentials are disabledMy workspace: Semantic model doesnt allow  refreshMy workspace: Semantic model doesnt allow refresh

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Kudoed Authors