Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
whereismydata
Resolver IV
Resolver IV

Encryption Support Message

Hi,

 

I get the following message when I connect to our on-prem SQL database with PowerBI or SSAS:

 

Encryption Support

We were unable to connect to the data source using an encrypted connection. To access this data source using an unencrypted connection, click OK

 

So, of course, clicking OK helps and I can connect to the database but I want to get rid of this message or at least understand the consequences of clicking this OK button.

 

I was told, all our connections are secured, but reading this message I'm not so sure

 

As mentioned, everything is on prem and protected by firewall. Authentication is via active directory/Windows.

 

Connecting to the sql server via report server does work without any problem/warning, or does clicking the OK button also surpress any warning on the report server side?

 

thank you!

 

1 ACCEPTED SOLUTION


@whereismydata wrote:

hi, yes, but that means that our sql server does not support encrypted connection at the moment?


No, your SQL Server instance might require configuration changes to support encryption. I would check with your DBA.

View solution in original post

4 REPLIES 4
v-alipat
Microsoft Employee
Microsoft Employee

Hi, 

Your SQL Server should be SSL-enabled 

Please check this link for more info: https://powerbi.microsoft.com/en-us/blog/ssl-security-error-with-data-source/ 

🙂

whereismydata
Resolver IV
Resolver IV

hi, yes, but that means that our sql server does not support encrypted connection at the moment?


@whereismydata wrote:

hi, yes, but that means that our sql server does not support encrypted connection at the moment?


No, your SQL Server instance might require configuration changes to support encryption. I would check with your DBA.

Shahfaisal
Solution Sage
Solution Sage

It is because the connections are encrypted by default but it can be turned off using File->Options and Settings -> Data Source Settings > SQL Server data source > Edit and uncheck "Encrypt Connections" option.

 

Here is a detailed answer - https://community.powerbi.com/t5/Desktop/connect-to-SQL-DB-prompt-quot-The-data-source-you-re-trying...

 

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.