Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Narendra24488
Regular Visitor

DM_GWPipeline_Client_MaxPacketLimitReached

I have a table with 40 columns and a parameter that filters the data, and connected via Direct Query. And having a Premium Capacity workspace. Based on the parameter selection, the report fetches a varying number of rows, ranging from 100 to approximately 400,000 to 500,000 rows. The paginated report successfully retrieves data for up to 200,000 rows. However, if the number of rows exceeds this limit, I encounter the following error:
Can anyone help me with how to fix this?


{"error":{"code":"DM_GWPipeline_Client_MaxPacketLimitReached","pbi.error":{"code":"DM_GWPipeline_Client_MaxPacketLimitReached","parameters":{},"details":[],"exceptionCulprit":1}}} ---------------------------- Query execution failed for dataset 'Catalog'. ---------------------------- An error has occurred during report processing. ---------------------------- An error occurred during local report processing

1 ACCEPTED SOLUTION
v-xiandat-msft
Community Support
Community Support

Hi @Narendra24488 ,

Since the issue occurs when fetching more than 200,000 rows, consider implementing pagination in your report. Fetch smaller chunks of data at a time to avoid hitting the limit.

Ensure that your query is optimized to fetch only the necessary data. Consider applying more specific filters or reducing the number of columns if possible. This can significantly reduce the data size being processed.

Enable query folding, which means that Power BI converts queries into more efficient forms that can be executed directly on a data source, such as SQL Server.

Below is the official link will help you:

Understanding query evaluation and query folding in Power Query - Power Query | Microsoft Learn

Best Regards,

Xianda Tang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
v-xiandat-msft
Community Support
Community Support

Hi @Narendra24488 ,

Since the issue occurs when fetching more than 200,000 rows, consider implementing pagination in your report. Fetch smaller chunks of data at a time to avoid hitting the limit.

Ensure that your query is optimized to fetch only the necessary data. Consider applying more specific filters or reducing the number of columns if possible. This can significantly reduce the data size being processed.

Enable query folding, which means that Power BI converts queries into more efficient forms that can be executed directly on a data source, such as SQL Server.

Below is the official link will help you:

Understanding query evaluation and query folding in Power Query - Power Query | Microsoft Learn

Best Regards,

Xianda Tang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

Top Solution Authors