Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Frequent Visitor

Authentication Required - Remove this step



The reporting setup is on-premise and consists of Power BI Report Server, has various types of PBIX files in imported mode and few direct query access and many other.

There is AD based authetication provisioned to all the above PBIX reports.

There is no SSAS and the PBIX files are linked to SQL Server.


Issue :

When I try to open the web URL of Power BI I get the popup as attached in the screenshot. I am already logged in into the Computer and still asks for Authentication. When I give the credentials it takes me to the Report Folders and so on and does ask for further authentication to the PBIX files and so on.



Is there a possibility that this extra step of Authentication is removed when users have already logged in into the machines?



Helper V
Helper V

What is your authentication setting? Are you using Kerberos?

Frequent Visitor

Currently, we are using Active Directory to give access to the PBIX files. Users use a the Report Server weblink and a prompt comes up asking for authentication. Users use their Windows Credentials to login. 




Getting prompted means either you are not using Kerberos, i.e. using NTLM authentication, or your setup of Kerberos is not correct. Please refer to here for more info:
Frequent Visitor

After further communications and readings I found that "smoupre" has commented about the single sign-on using ADFS Server. below is the link


I am trying to find the documentation references for implementation of this but also there is only little I can do here to implement due to the nature of the project. I am trying to get the information from Power BI developer/solutions perspective what information should I be sharing with the Infrastructure team so that they can implement it.


In addition to ADFS Server, there is another option "Azure AD Pass Through Authentication".




Hi, it is hard to be sure (because you offuscated your URL), but I guess that you are using a FQDN name on your URL. Are you?


If yes, by security reasons, your browser will not try to impersonate the authenticated user. To solve this problem, you sould add your domain to the Local Intranet configuration of your browser (something like * This can also be done for all the machines using a police on AD.


You can find more about it on the following link :



Helpful resources

Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City


Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.