Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
peterg_intervat
New Member

Unable to read data from the transport connection:

Hi

 

So aver the last two to three days I am having a varieity of issue with my Odata connection to CRM online. At first it was complaining with teh following error when trying to refresh the datasource:

 

"Data response result. Error: The property 'bizmap_businessid_businessunit' does not exist on type 'Microsoft.Crm.Sdk.Data.Services.BusinessUnit'." - So i assumed that a field that was part of a dataset had been changed, so i rebuilt the query in PowerBi Desktop (testing the refresh with no error" and republished.

 

Has the same issue again, which is odd as i tested the refresh on the desktop publisher with no errors.

 

Then forced a refresh again a few hours later and get a different error:

"Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host."

 

The odd thing is that this all worked fine for about 1 month up until 2 days ago.

 

Does anyone have any ideas.

 

Thank you in advance

18 REPLIES 18
rabihbadr
Frequent Visitor

Experiencing same issue while refreshing my queries, source is Onedrive, any update?

RaoMohsin6054
Regular Visitor

Power BI Desktop to the latest version and adjust parallel loading settings to prevent simultaneous execution of multiple queries, ensuring a successful report refresh. However, this may lead to a longer refresh time compared to parallel processing.

Read article: https://medium.com/microsoft-power-bi/resolving-unable-to-read-data-from-the-transport-connection-er...

NoMoreBugs
Advocate I
Advocate I

I had this problem yesterday and this morning. My colleague found that changing the internet or wifi solved the issue for our case. 

This also fixed the issue for me. I was connected via an ethernet cable, decided to switch to WiFi and the fix was instant. This fix makes no sense whatsoever given that the internet source is the same.

This worked for me! I would not have tried it if it wasn't because I've been having all other kinds of issues due to my connection. I switched from my 5G to normal wifi band and my dataset uploaded.

Deiaeldin80
New Member

This issue happened with my while running several Dataflows from datasource folder in Onedrive or sharepoint, it kind of make sense that the source folder serve only one connection at a time, i resolved it by running schedual refresh time of my dataflow in a way that allow not more than two dataflow connections to hit the source folder at the same time, depends (offcourse on the datasize) leaving a reasonable gap to (30 Minutes) between every connection. it might not be a perfect solution but it gets the job done eventually 🙂

saunders
Helper II
Helper II

Hey, just wanted to add that we're getting this error as well.  Are there any other logs we can check in PowerBI to get more of an idea of what's going on?  If any find a solution can you pls post.

Thanks heaps.

Hi @saunders,

Yes Saunders, I have used fetchxml as part of web query to extract data. I have also submitted a blog for same.

However it is pending for approval from Microsoft.

 

BR,

Achin

Hi I'm also eager to read your blog posting to resolve this problem. Did your blog posting ever get approved or can we see the info on some other non MS approved blog ? Please do let us know.

 

Trying to resolve a Power BI desktop connection to Dynamics 365 online instance using:

let
Source = OData.Feed("https://DOMAIN.crm4.dynamics.com/XRMservices/2011/OrganizationData.svc"),
ContactSet_table = Source{[Name="ContactSet",Signature="table"]}[Data]

 

Will be checking logs, fiddler etc....but still keen to read your blog.

Thks.

Hi @DavidMoss,

 

Please check this URL :

My blog was published few months back.

 

https://community.powerbi.com/t5/Community-Blog/CRM-Online-issues-with-oData-and-solution-with-Fetch...

 

Please do let me know if you have any questions.

BR,

Achin

achinm45
Advocate IV
Advocate IV

Hi @peterg_intervat

Have you got the solution ?

 

BR,
Achin

Hi there

 

No solution to this yet. This problem comes and goes. Which sadly impacts the business case to make it a permanent solution. I am not sure if it has to do with the fact that the feed timesout. It would be awesome if the feed would be more "real time" 🙂

 

Kind regads

Hi @peterg_intervat

Thank You for information !

I am also using CRM Online. Now I suspect, CRM online can also be possible suspect for problem.

Do we have setting where CRM online closes the connection ? I am not CRM online expert but do you have any idea

 

BR,

Achin

Hi @peterg_intervat, @solaris_rapido

I have published a blog for this issue and solution to it.

 

Please do check it here

 

I hope it helps you !

BR,

Achin Maheshwari

 

 

Hi @achinm45

 

Thank you for this. Seems like i dont have access to this. Any Chance you can grant me access. I would really be interested to see your solution.

 

Kind regads

Peter Gaertner

Hi @peterg_intervat,

I am unable to find any acess button or functionality for providing you access.

Seems Power BI team has not reviewed the article yet. It is in my staging area and has not been published to all.

I will post again on this forum when the blog gets published.

BR,
Achin

solaris_rapido
Microsoft Employee
Microsoft Employee

I'm getting the same error for the past two days even though mine was also working fine up to then.

Hi @solaris_rapido

Has your issue been resolved and how ?

I am facing same error and not getting a hint.

 

BR,

Achin

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors