Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Anonymous
Not applicable

Load was cancelled by an error in loading a previous table.

Ok so I'm losing my mind somewhat. I'm getting the subject message repeatedly and I've tried each of the other posts and Stackflow that speak to this and I'm still coming up short. 

 

Basically each week we pull a report from an enterprise system that exports as an Excel file. We do this every week, and so I've built the PowerQuery to essentially pull the most recent file from the file folder and manipulate the data so it's useful for our internal reporting purposes. 

 

Everything is working totally fine in PowerQuery, I have no errors on the file, and when I look at the end of the steps it looks to be the way I would like to see it. But when I go to the data visualization the visualization has not updated and if I go to look at the data, not in PowerQuery, but on the tabs on the left of the window. The source file's name shows something from a few months ago.

 

When I click to refresh I get "Load was cancelled by an error in loading a previous table."

 

Please help. 

Here are some screen grabs of what's happening.

 

Here is the file folder we are saving the original file to

fepowers_0-1593552033578.png

 

 

Here is what Power Query looks like editor looks like after I've refreshed the preview with the newest file.

fepowers_1-1593552174074.png

And finally, here is what the data view looks like with the not correct source file listed

fepowers_2-1593552229840.png

and this is what I get when I click refresh

fepowers_3-1593552282479.png

Literally out of ideas and yes I've deleted everything and restarted at least 3 times.

 

Thank you!!!

7 REPLIES 7
Anonymous
Not applicable

I delete/deactive all the relatiomships cross the tables. Then I can refresh.

Smauro
Solution Sage
Solution Sage

Hi @Anonymous 

Have you solved your issue?

If not, after seeing your screenshots I've got a long shot answer. Skip to the end for a possible quickfix.

Because:
a) I see you've recently archived the datasources.
b) I see that you select the folder and then apply some filter.
c) You have used automated transform functions.
d) You don't see any specific error.

It could be that some query is now getting both archive and current file, hence some steps later on it errors due to duplicates, or because the transformation function is tuned to the previous file, there were changes inbetween the archive and new version, thus not giving the desired results.
Now, in query editor everything seems fine, but that's because we're only getting the first 200 values and checking the first 1000 values -- if I remember the numbers correctly; I may be wrong on that.


About d), if you don't see any specific error but if it stops at evaluation, you should know you've got a column issue, but if it stops while trying to load data then it could also be a value issue. If it stops after loading everything, this could point to a column mismatch between evaluating the queries at 0row level and evaluating the queries.

 

Try quickfix:
Anyway, before (un)checking enable load on every query or actually changing any query to remove your issue, you could:
1) try to revert back to the archived by geting the new files to a different folder temporarily and see if it works.
if 1, 2) take the archived in a different folder and see if it works.

But if you're actually loading one file at a time then you should be using multiple file transform functions.

Cheers




Feel free to connect with me:
LinkedIn

lbendlin
Super User
Super User

Scroll down on the error message until you hit the query that is actually erroring out.

Anonymous
Not applicable

Each one of the errors shows the same "Load cancelled by an error....

Hi @Anonymous ,

 

Have you disabled the option "Enable Load" ? If yes, check this table or the sample file you are using as model, if that is the case.



Did I answer your question? Mark my post as a solution!

Proud to be a Super User!



Anonymous
Not applicable

On each query I have enabled load selected. Is there somewhere else I should be enabling it?

what @camargos88 is hinting at is a way to troubleshoot the issue.  Disable them all and then enable them one by one to see where it breaks.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors