Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
OH_Sport
New Member

Data Transformation word to numbers

 

Hi,

i loaded a gps-file into PowerBI and try to transform the data.
The GPS data of total distance (in meters) and total acceleration load (total number) are initally categorized as text. when i changed to number, the metrics are lost and i got a number withouth comma. I do not know how to change the metrics, that i got the correct number for total distance in meter (it would be for the first line 2898.45... and the secon 4387.57...) neither does the round up / round down work. 

What are steps, which i have to do to achieve my goal?

Oliver

OH_Sport_0-1714655223589.png

 

2 ACCEPTED SOLUTIONS
Greg_Deckler
Super User
Super User

@OH_Sport Only thing I can think of is that your regional settings have something other than "." set for decimal? I know some countries use "," for that. So you are saying that originally Total Distance was 2898.45093 and when you converted it to decimal number that it just ignored the ".". Unable to replicate that in my testing. See attached PBIX below sig. Possibly you could use the convert "from locale" and choose English - US?


Follow on LinkedIn
@ me in replies or I'll lose your thread!!!
Instead of a Kudo, please vote for this idea
Become an expert!: Enterprise DNA
External Tools: MSHGQM
YouTube Channel!: Microsoft Hates Greg
Latest book!:
The Definitive Guide to Power Query (M)

DAX is easy, CALCULATE makes DAX hard...

View solution in original post

v-junyant-msft
Community Support
Community Support

Hi @OH_Sport ,

@Greg_Deckler Your response gives everyone a good direction for troubleshooting. Thank you! If I remember correctly, in Belgium, for example, numbers are formatted with a "," for the decimal point.

@OH_Sport Depending on the region, I have tried to reproduce the situation you are facing. Here is my sample data:

vjunyantmsft_0-1714704631037.png

My area uses "." as a decimal point, but in the test data I use a comma as a decimal point.
Then I change it into Decimal Nmuber:

vjunyantmsft_1-1714704722986.png

The commas are lost.

Right-click the column header and select Using Locale in Change Type.

vjunyantmsft_2-1714704829298.png

Here I use Belgium as an example:

vjunyantmsft_3-1714704848639.png

And the final output is as below:

vjunyantmsft_4-1714704899107.png

 

Best Regards,
Dino Tao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-junyant-msft
Community Support
Community Support

Hi @OH_Sport ,

@Greg_Deckler Your response gives everyone a good direction for troubleshooting. Thank you! If I remember correctly, in Belgium, for example, numbers are formatted with a "," for the decimal point.

@OH_Sport Depending on the region, I have tried to reproduce the situation you are facing. Here is my sample data:

vjunyantmsft_0-1714704631037.png

My area uses "." as a decimal point, but in the test data I use a comma as a decimal point.
Then I change it into Decimal Nmuber:

vjunyantmsft_1-1714704722986.png

The commas are lost.

Right-click the column header and select Using Locale in Change Type.

vjunyantmsft_2-1714704829298.png

Here I use Belgium as an example:

vjunyantmsft_3-1714704848639.png

And the final output is as below:

vjunyantmsft_4-1714704899107.png

 

Best Regards,
Dino Tao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Greg_Deckler
Super User
Super User

@OH_Sport Only thing I can think of is that your regional settings have something other than "." set for decimal? I know some countries use "," for that. So you are saying that originally Total Distance was 2898.45093 and when you converted it to decimal number that it just ignored the ".". Unable to replicate that in my testing. See attached PBIX below sig. Possibly you could use the convert "from locale" and choose English - US?


Follow on LinkedIn
@ me in replies or I'll lose your thread!!!
Instead of a Kudo, please vote for this idea
Become an expert!: Enterprise DNA
External Tools: MSHGQM
YouTube Channel!: Microsoft Hates Greg
Latest book!:
The Definitive Guide to Power Query (M)

DAX is easy, CALCULATE makes DAX hard...

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors
Top Kudoed Authors